POJ 3268 Silver Cow Party (双图往返dijkstra)

Silver Cow Party
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 17024 Accepted: 7769

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ XN). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

题意:n个点,m条路,都要到第k个点去,问往返过程中,消耗最多的那个点

思路:建立双图,求两遍就可以了


ac代码:
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stack>
#include<set>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#define MAXN 1010000
#define LL long long
#define ll __int64
#define INF 0xfffffff
#define mem(x) memset(x,0,sizeof(x))
#define PI acos(-1)
#define eps 1e-8
using namespace std;
ll gcd(ll a,ll b){return b?gcd(b,a%b):a;}
ll lcm(ll a,ll b){return a/gcd(a,b)*b;}
ll powmod(ll a,ll b,ll MOD){ll ans=1;while(b){if(b%2)ans=ans*a%MOD;a=a*a%MOD;b/=2;}return ans;}
double dpow(double a,ll b){double ans=1.0;while(b){if(b%2)ans=ans*a;a=a*a;b/=2;}return ans;}
//head
int pri1[1010][1010];
int pri2[1010][1010];
int v[1010];
int dis1[1010],n;
int dis2[1010];
void debug()
{
    for(int i=1;i<=n;i++)
            printf("%d dis1=%d dis2=%d\n",i,dis1[i],dis2[i]);
}
void dijkstra(int x)
{
    int i,j;
    mem(v);
    for(i=1;i<=n;i++)
        dis1[i]=pri1[x][i];
        //debug();
    v[x]=1;
    dis1[x]=0;
    int M,k;
    for(i=0;i<n-1;i++)
    {
        M=INF,k=x;
        for(j=1;j<=n;j++)
        {
            if(!v[j]&&dis1[j]<M)
            {
                M=dis1[j];
                k=j;
            }
        }
        if(M==INF)
            break;
            //printf("M=%d k=%d\n",M,k);
        v[k]=1;
        for(j=1;j<=n;j++)
            if(!v[j]&&dis1[j]>dis1[k]+pri1[k][j])
            dis1[j]=dis1[k]+pri1[k][j];
    }
    //debug();
}
void ddijkstra(int x)
{
    int i,j;
    mem(v);
    //debug();
    for(i=1;i<=n;i++)
        dis2[i]=pri2[x][i];
        //debug();
    dis2[x]=0;
    v[x]=1;
    int M,k;
    for(i=0;i<n;i++)
    {
        M=INF,k=x;
        for(j=1;j<=n;j++)
        {
            if(!v[j]&&dis2[j]<M)
            {
                M=dis2[j];
                k=j;
            }
        }
        if(M==INF)
            break;
        v[k]=1;
        for(j=1;j<=n;j++)
            if(!v[j])
            dis2[j]=min(dis2[j],dis2[k]+pri2[k][j]);
    }
}
int main()
{
	int i,j,m,x;
	while(scanf("%d%d%d",&n,&m,&x)!=EOF)
	{
		for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
            pri1[i][j]=INF;
        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
            pri2[i][j]=INF;
        for(i=0;i<m;i++)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            pri1[a][b]=c;
            pri2[b][a]=c;
        }
        dijkstra(x);
        //debug();
        ddijkstra(x);
        int ans=-1;
        for(i=1;i<=n;i++)
            ans=max(ans,dis1[i]+dis2[i]);
        printf("%d\n",ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值