PAT 1014 Waiting in Line

PAT 1014 Waiting in Line

题目

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are: The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.Customer_i​ will take T_i​ minutes to have his/her transaction processed.
The first N customers are assumed to be served at 8:00am. Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.
For example, suppose that a bank has 2 windows and each window may have 2 customers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer_1 is served at window_1​ while customer_2​ is served at window_2 . Customer_3 will wait in front of window_1 and customer_4 will wait in front of window_2 . Customer_5 will wait behind the yellow line. At 08:01, customer_1 is done and customer_5 enters the line in front of window_1 since that line seems shorter now. Customer_2 will leave at 08:02, customer_4 at 08:06, customer_3 at 08:07, and finally customer_5 at 08:10.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).The next line contains K positive integers, which are the processing time of the K customers.
The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output Specification:

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

** Sample Input:**

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output:

08:07
08:06
08:10
17:00
Sorry

题解

该题可描述为解决K个人的n个队列的排队问题。且每个队列规定了最长长度m。若各队都满员了,后面序号的人需要等任一队列中的人服务完毕才能入队。若队伍不满,未入队的进入最短的那个队伍,若队伍同长,优先进入序号在前面的队。所有人8点到银行,若到17点时仍然未开始服务到的人,今天不再接受服务。

可以采用多个队列来解决该问题。模拟入队的情况,遍历所有人,先找最短队列,若最短队列未满,将该人入队,并递归地计算出队时间,其等于队伍前一个人的出队时间加上自己的服务时间(注意:如果前一个人服务时间超过17点,则最后需输出Sorry, 忽略这点是测试点2、4、5错误的原因

时间复杂度O(Kn), 空间复杂度O(nm)

代码

def show(ti):
    if ti == -1:
        return "Sorry"
    h, m = ti // 60, ti % 60
    return str(h + 108)[1:] + ":" + str(100 + m)[1:]


if __name__ == "__main__":
    n, m, k, q = list(map(int, input().split()))
    times = list(map(int, input().split()))
    queries = list(map(int, input().split()))
    queues = [[] for i in range(n)]
    end_time = []
    lens = [0] * n
    for i, t in enumerate(times):
        ml = min(lens)
        j = -1
        if ml == m:
            first = [queues[k][0] for k in range(n)]
            fm = min(first)
            for fi in first:
                j += 1
                if fi == fm:
                    break
            queues[j].append(queues[j][-1] + t)
            if queues[j][-2]<540:
                end_time.append(queues[j][-1]) 
            else:
                end_time.append(-1) 
            queues[j].pop(0)
        else:
            for mi in lens:
                j += 1
                if ml == mi:
                    break
            if ml > 0 and ml < m:
                queues[j].append(queues[j][-1] + t)
                if queues[j][-2] < 540:
                    end_time.append(queues[j][-1])
                else:
                    end_time.append(-1)
                lens[j] += 1
            elif ml == 0:
                queues[j].append(t)
                lens[j] += 1
                end_time.append(queues[j][-1])
    for q in queries:
        print(show(end_time[q - 1]))
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值