PAT 双指针

1044 Shopping in Mars 分数 25

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).

  1. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).

  1. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤105), the total number of diamonds on the chain, and M (≤108), the amount that the customer has to pay. Then the next line contains N positive numbers D1⋯DN (Di≤103 for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i ≤ j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + ... + Dj >M with (Di + ... + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4

题解

题目可以描述为:找到一个序列里的所有子序列和大于等于num的最小子序列和对应的子序列

思路

采用双指针,i表示子序列的开头,j子序列的结尾,先逐步增大j,直到子序列和大于目标,此时这个序列是以i开头的最可能符合的序列,记录此序列, 并且第i+1开头的子序列其符合条件的结尾必定会大于j,所以i+1,j从当前位置再增大,直到j增大到满足条件或结尾。一直遍历i到最后一个数,在遍历时维护一个子序列和与目标值的差值d,每次变动一下i或者j时,差值减小a[j]或增大a[i],这样就可以不用每次都求i到j序列的和,并且维护最小差值和最小差值的数组

AC 代码

n, k = map(int, input().split())
dn = list(map(int, input().split()))
i, j = 0, 0
diff = k 
mindiff, res = -1e9, []
while i<n: 
    while diff>0 and j<n:
        diff -= dn[j]
        j+=1
    if diff<=0:
        if diff>mindiff:
            res = [(i, j)]
            mindiff = diff
        elif diff== mindiff:
            res.append((i,j))
        diff += dn[i]
        i+=1
    else:
        break  # 剪枝
for i, j in res:
    print(f"{i+1}-{j}")
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值