PTA-双指针(1029/1044)

1029 Median (25 分)

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×105) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

思路

双指针一道基础题,合并序列后的中间值可以滑动寻找两个序列的较小值,找到第(m+n-1)/2个,即是想要寻找的中位数。

#include<bits/stdc++.h>
using namespace std;
const int maxx=2e5+1;
int main()
{
	int n,m;
	long a[maxx],b[maxx];
	cin>>n;
	for(int i=0;i<n;i++)
	{
		cin>>a[i];
	}
	cin>>m;
	for(int i=0;i<m;i++)
	{
		cin>>b[i];
	}
	int mid=(n+m-1)/2;
	a[n]=INT_MAX,b[m]=INT_MAX;
	int cnt=0;
	int i=0,j=0;
	while(cnt<mid){
		if(a[i]<=b[j]) i++;
		else j++; 
		cnt++;
	}
	cout<<min(a[i],b[j]);
	return 0;
}

实际上,可以暴力求解

#include<bits/stdc++.h>
using namespace std;
int main()
{
	int n,m;
	vector<long> a,b;
	cin>>n;
	for(int i=0;i<n;i++){
		int x;
		cin>>x;
		a.push_back(x);
	}
	cin>>m;
	for(int i=0;i<m;i++){
		int x;
		cin>>x;
		b.push_back(x);
	}
	a.insert(a.end(),b.begin(),b.end());
	sort(a.begin(),a.end());
	int mid=(n+m)/2;
	cout<<a[mid];
	return 0;
}

1048 Find Coins (25 分)

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤105, the total number of coins) and M (≤103
, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V1andV2(separated by a space) such that V1+V 2=M and V1≤V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output No Solution instead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution

思路

双指针的基础题,设置头和尾,向排好序的序列中间扫描,如果大于m就左移e,小于m就右移s,直到s==e扫描完整个序列,还没有找到就返回no solution,找到了就立即中断跳出,输出v1最小的那组值。

#include<bits/stdc++.h>
using namespace std;
int main()
{
	int n,m;
	cin>>n>>m;
	vector<int> a;
	for(int i=0;i<n;i++)
	{
		int x;
		cin>>x;
		a.push_back(x);	
	}	
	sort(a.begin(),a.end());
	int s=0,e=n-1;
	bool pan=false;
	while(s<e){
		if(a[s]+a[e]>m) e--;
		else if(a[s]+a[e]<m) s++;
		else{
			pan=true;
			break;
		} 
	}
	if(pan){
		cout<<a[s]<<' '<<a[e];
	}
	else cout<<"No Solution";
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

新西兰做的饭

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值