HDU1018 Big Number

Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 
Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.
 
Output

            The output contains the number of digits in the factorial of the integers appearing in the input.
 
Sample Input
2
10
20
 
Sample Output
7
19
这个题就是要求阶乘的位数,直接求出阶乘肯定行不通,数值太大了。

可以讲N!转换成10^m,例如10!=3628800=3.628800*10^6,两边求对数得到log10(3628800)=log10(3.628800)+6

所以10!的位数就是6+1=7位。所以阶乘的位数可以用int(log10(n!))+1表示。

log10(n!)=log10(1*2*3*4*...*n)=log10(1)+log10(2)+log10(3)+...+log10(n);

代码如下:

#include <stdio.h>
#include <stdlib.h>
#include <math.h>
int main()
{
    int n,t;
    double sum,i;
    scanf("%d",&t);
    while(t--)
    {
        sum=0;
        scanf("%d",&n);
        for(i=1;i<=n;i++)
        {
            sum+=(double)log10(i);
        }
        printf("%d\n",(int)sum+1);
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值