D - Milking Time
Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.
Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.
Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.
Input
* Line 1: Three space-separated integers: N, M, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi
Output
* Line 1: The maximum number of gallons of milk that Bessie can product in the Nhours
Sample Input
12 4 2
1 2 8
10 12 19
3 6 24
7 10 31
Sample Output
43
题目大意:
首先按开始时间排序,然后
f[i]表示前i个最多能够挤得的奶,那么有
f[i]=w[i],初始化
f[i]=max(f[i], f[j]+w[i]) 当j的结束时间+R不超过i的开始时间
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
struct node{
int star;
int end;
int eff;
}cow[1005];
bool cmp(node a,node b){
if(a.star==b.star){
return a.end<b.end;
}
return a.star<b.star;
}
int main(){
int dp[1005];
int N,M,R;
cin>>N>>M>>R;
for(int i=0;i<M;i++){
cin>>cow[i].star>>cow[i].end>>cow[i].eff;
}
sort(cow,cow+M,cmp);//
for(int i=0;i<M;i++){
dp[i]=cow[i].eff;
}
int ans=0;
for(int i=0;i<M;i++){
for(int j=0;j<i;j++){
if(cow[i].star>=cow[j].end+R){ //
dp[i]=max(dp[i],dp[j]+cow[i].eff);//
}
}
ans=max(ans,dp[i]);//
}
cout<<ans<<endl;
}