Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16150 Accepted Submission(s): 6550
Problem Description
Write a program to read in a list of integers and determine whether or not each number is prime. A number, n, is prime if its only divisors are 1 and n. For this problem, the numbers 1 and 2 are not considered primes.
Input
Each input line contains a single integer. The list of integers is terminated with a number<= 0. You may assume that the input contains at most 250 numbers and each number is less than or equal to 16000.
Output
The output should consists of one line for every number, where each line first lists the problem number, followed by a colon and space, followed by "yes" or "no".
Sample Input
1 2 3 4 5 17 0
Sample Output
1: no 2: no 3: yes 4: no 5: yes 6: yes
Source
2008 “Sunline Cup” National Invitational Contest - Warm Up
#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;
#define ll long long
#define N 100
bool isprime[N];//1
int pri[N];//2
void prime()
{
int cnt=1;
memset(pri,0,sizeof(pri));
isprime[1]=1;
for(int i=2;i<=sqrt(N);i++)//3
{
if(!isprime[i])
{
pri[cnt++]=i;//4
for(int k=i*i;k<=N;k+=i)//5
{
isprime[k]=1;//表示k是一个合数
}
}
}
return;
}
#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;
#define ll long long
#define N 100
bool isprime[N];
int pri[N];
void prime2()
{
int cnt=1;
memset(pri,0,sizeof(pri));
isprime[1]=1;
for(int i=2;i<=N;i++)
{
if(!isprime[i])
{
pri[cnt++]=i;
}
for(int j=1;j<cnt&&i*pri[j]<=N;j++)//1
{
isprime[i*pri[j]]=1;
if(i%pri[j]==0)//2
break;
}
}
return;
}
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <string>
#define ll long long
#define maxx 100000000
using namespace std;
int pri[maxx];
bool isprime[maxx];
void prime()
{
int cnt=1;
memset(pri,0,sizeof(pri));
isprime[1]=1;
for(int i=2;i<=sqrt(maxx);i++)
{
if(!isprime[i])
{
pri[cnt++]=i;
for(int k=i*i;k<=maxx;k+=i)
{
isprime[k]=1;
}
}
}
}
int main()
{
prime();
int n,m;
cin>>n>>m;
for(int i=n;i<=m;i++)
{
cout<<pri[i]<<" ";
}
return 0;
}
/*1000000 168
10000000 446
100000000 1229
*/