POJ 3468 线段树区间更新 懒惰标记 区间求和

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 132386 Accepted: 41056
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source

POJ Monthly--2007.11.25, Yang Yi

题意 两个操作 Q查询某一段区间

                          C 给某一段区间都加上一个数

以为很简单 随便敲了一下第一发WA 后来发现是int溢出 啥时候才能改掉自己节省空间 不看范围 没有1Y的坏习惯呢?

#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;
const int MAX_N = 100010;
long long s[MAX_N<<2];
int col[MAX_N<<2];
int n;
void up(int p){
   s[p]=s[p*2]+s[p*2+1];
}
void build(int p,int l,int r){
   if(l==r){
    scanf("%lld",&s[p]);
    return;
   }
   int mid =(l+r)>>1;
   build(p*2,l,mid);
   build(p*2+1,mid+1,r);
   up(p);
}
void down(int p,int l,int r){
   if(col[p]){
    int mid = (l+r)>>1;
    col[p*2]+=col[p];
    col[p*2+1]+=col[p];
    s[p*2]+=1LL*col[p]*(mid-l+1);
    s[p*2+1]+=1LL*col[p]*(r-mid);
    col[p] = 0;
   }
}
void change(int p,int l,int r,int x,int y,long long v){
     if(x<=l&&r<=y){
        col[p]+=v;
        s[p]+=1LL*v*(r-l+1);
        return ;
     }
     int mid = (l+r)>>1;
     down(p,l,r);
     if(x<=mid) change(p*2,l,mid,x,y,v);
     if(y>mid) change(p*2+1,mid+1,r,x,y,v);
     up(p);
}
long long query(int p,int l,int r,int x,int y){
    if(x<=l&&r<=y){
        return s[p];
    }
    down (p,l,r);
    int mid =(l+r)>>1;
    long long res = 0;
    if(x<=mid) res+=query(p*2,l,mid,x,y);
    if(y>mid) res+=query(p*2+1,mid+1,r,x,y);
    return res;
}

int main(){
    int m;
    scanf("%d%d",&n,&m);
    build(1,1,n);
    while(m--){
        char str[20];
        scanf("%s",str);
        string str_ = str;
        if(str_=="C"){
            int a,b;
            long long c;
            scanf("%d%d%lld",&a,&b,&c);
            change(1,1,n,a,b,c);
        }
        else if(str_=="Q"){
            int a,b;
            scanf("%d%d",&a,&b);
            printf("%lld\n",query(1,1,n,a,b));
        }
    }
   return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值