HDU 3308 LCIS 线段树维护区间LCIS

LCIS

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8537    Accepted Submission(s): 3662


Problem Description
Given n integers.
You have two operations:
U A B: replace the Ath number by B. (index counting from 0)
Q A B: output the length of the longest consecutive increasing subsequence (LCIS) in [a, b].
 

Input
T in the first line, indicating the case number.
Each case starts with two integers n , m(0<n,m<=10 5).
The next line has n integers(0<=val<=10 5).
The next m lines each has an operation:
U A B(0<=A,n , 0<=B=10 5)
OR
Q A B(0<=A<=B< n).
 

Output
For each Q, output the answer.
 

Sample Input
 
 
1 10 10 7 7 3 3 5 9 9 8 1 8 Q 6 6 U 3 4 Q 0 1 Q 0 5 Q 4 7 Q 3 5 Q 0 2 Q 4 6 U 6 10 Q 0 9
 

Sample Output
 
 
1 1 4 2 3 1 2 5
 

Author
shǎ崽
 

Source

题目传送门

题意 两个操作 替换第a+1(从1开始)个数为b

                    查询 a-b区间内的最长LCIS长度

这样我们建树 只要存储区间右端点值 左端点值 中间最大LCIS 左边最大LCIS 右边最大LCIS

分别用数组去体现 代码如下

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ;

const int maxN = 1000000 ;

int lnum[maxN] , rnum[maxN] ;//左数 右数
int lmax[maxN] , rmax[maxN] , mmax[maxN] ;//左边最大的LCIS长度 右边 中间

int max ( const int X , const int Y ) {
	if ( X > Y ) return X ;
	return Y ;
}

int min ( const int X , const int Y ) {
	if ( X < Y ) return X ;
	return Y ;
}

void up ( int p , int len ) {
	lnum[p] = lnum[p*2] ;
	rnum[p] = rnum[p*2+1] ;
	lmax[p] = lmax[p*2] ;
	rmax[p] = rmax[p*2+1] ;
	mmax[p] = max ( mmax[p*2] , mmax[p*2+1] ) ;
	if ( rnum[p*2] < lnum[p*2+1] ) {
		mmax[p] = max ( mmax[p] , rmax[p*2] + lmax[p*2+1] ) ;
		if ( lmax[p*2] == (len-(len>>1)) ) {
			lmax[p] += lmax[p*2+1] ;
		}
		if ( rmax[p*2+1] == (len>>1) ) {
			rmax[p] += rmax[p*2] ;
		}
	}
}

void Build ( int p,int l , int r  ) {
	if ( l == r ) {
		int x ;
		scanf ( "%d" , &x ) ;
		lnum[p] = rnum[p] = x ;
		lmax[p] = mmax[p] = rmax[p] = 1 ;
		return ;
	}
	int mid = ( l + r ) >> 1 ;
	Build (p*2,l,mid) ;
	Build (p*2+1,mid+1,r) ;
	up ( p , r - l + 1 ) ;
}

void change ( int p, int l , int r,int x,int v ) {
	if ( l == r ) {
		lnum[p] = rnum[p] = v ;
		lmax[p] = mmax[p] = rmax[p] = 1 ;
		return ;
	}
	int mid = ( l + r ) >> 1 ;
	if ( x <= mid ) change(p*2,l,mid,x,v);
	else change(p*2+1,mid+1,r,x,v) ;
	up ( p , r - l + 1 ) ;
}

int Query ( int p,int l,int r,int x,int y) {
	if ( x <= l && r <= y ) return mmax[p] ;
	int mid = ( l + r ) >> 1 ;
	int tmp1 = 0 , tmp2 = 0 , tmp3 = 0 ;
	if ( x <= mid ) tmp1 = Query ( p*2,l,mid,x,y ) ;
	if ( mid <  y ) tmp2 = Query ( p*2+1,mid+1,r,x,y ) ;
	if ( x <= mid && mid < y && rnum[p*2] < lnum[p*2+1] ) tmp3 = min ( mid - x + 1 , rmax[p*2] ) + min ( lmax[p*2+1] , y - mid ) ;
	return max ( max ( tmp1 , tmp2 ) , tmp3 ) ;
}

void work () {
	int n , m , First , Second ;
	char ch[5] ;
	scanf ( "%d%d" , &n , &m ) ;
	Build ( 1 ,1,n ) ;
	while ( m -- ) {
		scanf ( "%s%d%d" , ch , &First , &Second ) ;
		if ( ch[0] == 'U' ) change ( 1,1,n,First+1,Second ) ;
		else printf ( "%d\n" , Query ( 1,1,n,First+1,Second+1 ) ) ;
	}
}

int main () {
	int T ;
	scanf ( "%d" , &T ) ;
	while ( T -- ) {
		work () ;
	}
	return 0 ;
}

 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值