POJ 2182 二分+树状数组

21 篇文章 0 订阅
20 篇文章 0 订阅
Lost Cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12536 Accepted: 8037

Description

N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands. 

Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow. 

Given this data, tell FJ the exact ordering of the cows. 

Input

* Line 1: A single integer, N 

* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on. 

Output

* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input

5
1
2
1
0

Sample Output

2
4
5
3
1

Source

USACO 2003 U S Open Orange

容易想到名次是全队中比你小的+1 也就是前面比你小的数量加上后面比你小的数量

前面比你小的数量也就是输入 且容易想到最后一名就是这个前面比你小的数量+1 因为后面没人比他小

那么我们从后面往前面扫 建立一个关系式 前面比你小的数量+后面比你小的数量+1==排名

也就是pos[i]+getsum(x)+1==x;

我们考虑下x和getsum(x)哪个变化速度更快

容易知道x快一点 所以二分的时候 如果左边小于等于右边

则要r=mid - 1 意思是想让x收的小一点

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;
#define dbg(x) cout<<#x<<" = "<< (x)<< endl
const int MAX_N = 1000010;
int C[MAX_N],vis[MAX_N];
int pos[MAX_N],ans[MAX_N];
int n;
int getsum(int x){
   int res = 0;
   for(;x;x-=x&(-x)){
    res+=C[x];
   }
   return res;
}
void change(int x){
    for(;x<=n;x+=x&(-x)){
        C[x]++;
    }
}

int main(){
    scanf("%d",&n);
    pos[1] = 0;
    for(int i=2;i<=n;i++)
        scanf("%d",&pos[i]);
    //vis[ans[n]]=1;
    for(int i = n;i>=1;i--){
        int l = 1,r = n;
        while(l<=r){
            int mid = (l+r)/2;
            if(getsum(mid)+pos[i]+1<=mid) r=mid-1;
            else l = mid +1;
        }
        ans[i] = l;
        //dbg(l);
        //dbg(pos[i]);
        //dbg(getsum(l));
        change(ans[i]);
        //dbg(ans[i]);
    }
    for(int i = 1;i<=n;++i)
        printf("%d\n",ans[i]);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值