Sicily 1121. Tri Tiling

34 篇文章 0 订阅
Description
In how many ways can you tile a 3x n rectangle with 2x1 dominoes?

Here is a sample tiling of a 3x12 rectangle.

Input
Input consists of several test cases followed by a line containing  -1. Each test case is a line containing an integer  0 ≤ n ≤ 30.
Output
For each test case, output one integer number giving the number of possible tilings.
Sample Input
 Copy sample input to clipboard
2
8
12
-1
Sample Output
3
153
2131
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

long long s[31];

long long num(int a)
{
	if(a == 0)
	{
		return 1;	
	}
	if(a == 2)
	{
		return 3;	
	}
	if(s[a] != 0)
	{
		return s[a];	
	}
	long long sum = 0;
	sum += 3 * num(a - 2);
	int temp = a - 2;
	while(temp > 0)
	{
		temp -= 2;
		sum += 2 * num(temp);
	}
	s[a] = sum;
	return sum;
	
}

int main()
{
	int n;
	memset(s, 0, sizeof(s));
	
	while(scanf("%d", &n) && n != -1)
	{
		if(n == 0)
		{
			printf("1\n");	
		}
		else if(n % 2 != 0)
		{
			printf("0\n");	
		}
		else
		{
			printf("%d\n", num(n));	
		}
	}
	return 0;	
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值