hdu 2604

Queuing

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
Queues and Priority Queues are data structures which are known to most computer scientists. The Queue occurs often in our daily life. There are many people lined up at the lunch time.

  Now we define that ‘f’ is short for female and ‘m’ is short for male. If the queue’s length is L, then there are 2 L numbers of queues. For example, if L = 2, then they are ff, mm, fm, mf . If there exists a subqueue as fmf or fff, we call it O-queue else it is a E-queue.
Your task is to calculate the number of E-queues mod M with length L by writing a program.
 

Input
Input a length L (0 <= L <= 10 6) and M.
 

Output
Output K mod M(1 <= M <= 30) where K is the number of E-queues with length L.
 

Sample Input
  
  
3 8 4 7 4 8
 

Sample Output
  
  
6 2 1
 

解题思路:这道题目乍一看没什么想法,但是仔细分析,每个字符无非就是f和m,肯定是存在递推的关系的。这里的地推关系如下:F(n) = F(n-1)+F(n-3)+F(n-4)。
因为不能够出现"fff"和“fmf”,所以我们只能三个三个地推导,假设第n个字母为m,那么肯定是没有限制的,有F(n-1)种,当最后三个字母为mmf时,有F(n-3)种,当最后三个字母为mff时,那么最后四个字母必须要是mmff才行,有F(n-4)种。。初始状态1-4都是已知的。
根据这个递推关系式,我们可以构建这样一个系数矩阵A=[1 0 1 1;1 0 0 0;0 1 0 0;0 0 1 0],求出A^n即可。。典型的矩阵快速幂的问题了。。

我的代码不知道为什么,提交的时候一直说Code Lenght improper。。。不知道咋回事。。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

struct Matrix
{
	int m[4][4];
};
Matrix base;
int l,mod,b[4][4]={{1,0,1,1},{1,0,0,0},{0,1,0,0},{0,0,1,0}};

Matrix mul(Matrix a,Matrix b)
{
	Matrix c;
	for(int i = 0; i < 4; i++)
		for(int j = 0; j < 4; j++)
			for(int k = 0; k < 4; k++)
			{
				c.m[i][j] = (c.m[i][j] + a.m[i][k] * b.m[k][j]) % mod;
			}
	return c;
}

Matrix power(int n)
{
	if(n <= 1) return base;
	Matrix c;
	c = power(n/2);
	c = mul(c,c);
	if(n % 2 == 1)
		c = mul(c,base);
	return c;
}

int main()
{	
	for(int i = 0; i < 4; i++)
		for(int j = 0; j < 4; j++)
			base.m[i][j] = b[i][j];
	int c[4] = {9,6,4,2};
	while(scanf("%d%d",&l,&mod)!=EOF)
	{
		if(l <= 4) 
		{
			printf("%d\n",c[4-l]%mod);
			continue;
		}
		Matrix a = power(l-5);
		int ans = 0;
		for(int i = 0; i < 4; i++)
			ans = (ans + a.m[0][i] * c[i]) % mod;
		printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值