PAT甲级 -- 1011 World Cup Betting (20 分)

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to WT and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31

未AC:出来结果都是对的,不知道为什么就是跑不过去,有大佬知道原因吗,求告知。。。

#include <iostream>
using namespace std;

double odds[3][3];
char three[3] = {'W', 'T', 'L'};
double sum;

int main()
{
    for(int i = 0; i < 3; i++)
    {
        scanf("%lf %lf %lf", &odds[i][0], &odds[i][1], &odds[i][2]);
    }
    sum = (odds[0][1] * odds[1][1] * odds[2][0] * 0.65 - 1) * 2;
    for(int i = 0; i < 3; i++)
    {
        int mx_num = 0, mx = -1;
        for(int j = 0; j < 3; j++)
        {
            if(odds[i][j] > mx)
            {
                mx_num = j;
                mx = odds[i][j];
            }
        }
        printf("%c ", three[mx_num]);
    }
    printf("%.2f", sum);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
As an AI language model, I can provide you with some guidance on how to implement a Texas Hold'em poker game in Clojure. However, I cannot write the entire code for you. Here are the general steps you can follow: 1. Define the data structures for the game, such as the deck of cards, player hands, and the community cards. 2. Write functions to shuffle the deck, deal the cards, and determine the winner of the game. 3. Implement the game logic, including the betting rounds, the flop, the turn, and the river. 4. Create a user interface for the game, which can be either a command-line interface or a graphical interface. Here is some sample Clojure code to get you started: ```clojure (def suits [:hearts :diamonds :clubs :spades]) (def ranks [:2 :3 :4 :5 :6 :7 :8 :9 :10 :J :Q :K :A]) (defn make-deck [] (for [suit suits rank ranks] {:suit suit :rank rank})) (defn shuffle-deck [deck] (shuffle deck)) (defn deal-hand [deck] (take 2 deck)) (defn deal-flop [deck] (take 3 (drop 2 deck))) (defn deal-turn [deck] (take 1 (drop 5 deck))) (defn deal-river [deck] (take 1 (drop 6 deck))) (defn evaluate-hand [hand community-cards] ;; Implement the hand evaluation logic here ) (defn determine-winner [hands community-cards] (let [evaluated-hands (map #(evaluate-hand % community-cards) hands) max-hand (apply max evaluated-hands)] (nth hands (.indexOf evaluated-hands max-hand)))) (defn play-game [] (let [deck (make-deck) shuffled-deck (shuffle-deck deck) player-hands (for [_ (range 4)] (deal-hand shuffled-deck)) flop (deal-flop shuffled-deck) turn (deal-turn shuffled-deck) river (deal-river shuffled-deck) community-cards (concat flop turn river)] (determine-winner player-hands community-cards))) ;; Example usage: (play-game) ``` This is just a basic implementation, and you will need to add more features to make it a fully functional game. Good luck!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值