The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3,105]), followed by N integer distances D1 D2 ⋯ DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.
Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7
最后一个点运行超时:
#include <iostream>
using namespace std;
const int maxn = 100010;
int n, m;
long long dis[maxn];
long long sum_dis = 0;
int e1, e2;
int main()
{
scanf("%d", &n);
for(int i = 1; i <= n; i++)
{
scanf("%lld", &dis[i]); //i到i+1的距离
sum_dis += dis[i];
}
scanf("%d", &m);
for(int i= 0; i < m; i++)
{
long long sum = 0;
scanf("%d%d", &e1,&e2);
if (e1 > e2)
{
int tmp = e1;
e1 = e2;
e2 = tmp;
}
for(int j = e1; j < e2; j++)
{
sum += dis[j];
}
if (sum < sum_dis - sum)
{
printf("%lld\n", sum);
}else
{
printf("%lld\n", sum_dis - sum);
}
}
return 0;
}
正确code:
降低复杂度:
求出所以从1到其他结点的距离,A到B的距离(B>A)记作(B到1的距离-A到1的距离),比较环形从两边出发的长度,取最小值
#include <iostream>
#include <cmath>
using namespace std;
const int maxn = 100010;
int n, m;
long long dis[maxn], a[maxn];
long long sum_dis = 0;
int e1, e2;
int main()
{
scanf("%d", &n);
for(int i = 1; i <= n; i++)
{
scanf("%lld", &dis[i]); //i到i+1的距离
sum_dis += dis[i];
a[i] = sum_dis;
}
scanf("%d", &m);
for(int i= 0; i < m; i++)
{
scanf("%d%d", &e1,&e2);
if (e1 > e2)
{
int tmp = e1;
e1 = e2;
e2 = tmp;
}
long long temp = a[e2-1] - a[e1-1];
printf("%lld\n", min(temp, sum_dis - temp));
}
return 0;
}