Given two strings S1 and S2, S=S1−S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1−S2 for any given strings. However, it might not be that simple to do it fast.
Input Specification:
Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.
Output Specification:
For each test case, print S1−S2 in one line.
Sample Input:
They are students.
aeiou
Sample Output:
Thy r stdnts.
3分:
getchar()把第一个字符读取了
#include <iostream>
#include <string>
using namespace std;
string s1, s2;
bool asc[256] = {false};
int main()
{
getline(cin,s1);
getchar();
getline(cin,s2);
int len1 = s1.length(), len2 = s2.length();
for(int i = 0; i < len2; i++)
{
asc[s2[i]] = true;
}
for(int i = 0; i < len1; i++)
{
if(asc[s1[i]] == true) continue;
else printf("%c",s1[i]);
}
return 0;
}
20分:
#include <iostream>
#include <string>
using namespace std;
string s1, s2;
bool asc[256] = {false};
int main()
{
getline(cin,s1);
getline(cin,s2);
int len1 = s1.length(), len2 = s2.length();
for(int i = 0; i < len2; i++)
{
asc[s2[i]] = true;
}
for(int i = 0; i < len1; i++)
{
if(asc[s1[i]] == true) continue;
else printf("%c",s1[i]);
}
return 0;
}