PAT甲级 -- 1102 Invert a Binary Tree (25 分)

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

我的思路:

1. 跟之前1110 很相似的一道题!但是输入时的处理逻辑需要变换一下,因为求反转树,即左结点 -> 右结点,右结点 -> 左结点。注意要充分考虑到所有情况。hash数组找没有出现过的数字,即根。

2. 用一个dfs控制层序和中序。建立lay数组和pre数组,lay[i] 保存深度为 i 那层的结点,pre保存中序序列。

#include <iostream>
#include <vector>
using namespace std;
struct node{
	int left, right;
}a[20];
int n;
int maxDepth = 0;
vector<int> lay[20], preOrder;
void dfs(int root, int depth){
	if(depth > maxDepth){
		maxDepth = depth;
	}
	if(a[root].left != -1) dfs(a[root].left, depth+1);
	lay[depth].push_back(root);
	preOrder.push_back(root);	
	if(a[root].right != -1) dfs(a[root].right,depth+1);
}
int main(){
	scanf("%d", &n);
	int hash[20] = {0}, root = 0;
	for (int i = 0; i < n; i++){
		string n1, n2;
		cin >> n1 >> n2;
		if(n1 == "-" && n2 != "-"){
			a[i].left = stoi(n2);
			hash[stoi(n2)] = 1;
			a[i].right = -1;
		}else if(n1 != "-" && n2 == "-"){
			a[i].right = stoi(n1);
			hash[stoi(n1)] = 1;
			a[i].left = -1;
		}else if(n1 == "-" && n2 == "-"){
			a[i].left = -1;
			a[i].right = -1;
		}else{
			a[i].left = stoi(n2);
			a[i].right = stoi(n1);
			hash[stoi(n1)] = 1;
			hash[stoi(n2)] = 1;
		}
	}
	while(hash[root] == 1) root++;
	dfs(root, 0);
	printf("%d", lay[0][0]);
	for(int i = 1; i <= maxDepth; i++){
		for(int j = 0; j < lay[i].size(); j++){
			printf(" %d", lay[i][j]);
		}	
	}
	printf("\n");
	printf("%d", preOrder[0]);
	for(int i = 1; i < preOrder.size(); i++){
		printf(" %d", preOrder[i]);
	}
	return 0;
}

看了看柳神的代码:

1. 录入时没有进行处理,在遍历的时候进行交换。 左根右 -> 右根左

2. 全部记录信息的好处就是不用记录最大层序,直接将结点进行排序就可以输出层序从小到大。

3. 按level排序即层序输出,不排序输出就是中序。注意vector<int> v2(v1) 要进行复制

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
struct node {
    int id, l, r, index, level;
} a[100];
vector<node> v1;
void dfs(int root, int index, int level) {
    if (a[root].r != -1) dfs(a[root].r, index * 2 + 2, level + 1);
    v1.push_back({root, 0, 0, index, level});
    if (a[root].l != -1) dfs(a[root].l, index * 2 + 1, level + 1);
}
bool cmp(node a, node b) {
    if (a.level != b.level) return a.level < b.level;
    return a.index > b.index;
}
int main() {
    int n, have[100] = {0}, root = 0;
    cin >> n;
    for (int i = 0; i < n; i++) {
        a[i].id = i;
        string l, r;
        cin >> l >> r;
        if (l != "-") {
            a[i].l = stoi(l);
            have[stoi(l)] = 1;
        } else {
            a[i].l = -1;
        }
        if (r != "-") {
            a[i].r = stoi(r);
            have[stoi(r)] = 1;
        } else {
            a[i].r = -1;
        }
    }
    while (have[root] == 1) root++;
    dfs(root, 0, 0);
    vector<node> v2(v1);
    sort(v2.begin(), v2.end(), cmp);
    for (int i = 0; i < v2.size(); i++) {
        if (i != 0) cout << " ";
        cout << v2[i].id;
    }
    cout << endl;
    for (int i = 0; i < v1.size(); i++) {
        if (i != 0) cout << " ";
        cout << v1[i].id;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值