1102 Invert a Binary Tree (25分)---二叉树的层次和中序遍历

37 篇文章 0 订阅

https://pintia.cn/problem-sets/994805342720868352/problems/994805365537882112

1102 Invert a Binary Tree (25分)

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can’t invert a binary tree on a whiteboard so fuck off.
Now it’s your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1
反转一下左右子树

#include<bits/stdc++.h>
using namespace std;
struct Node{
	int left,right;
}node[10];
bool t[10]={false};		//记录子树中出现的结点
int N,s=0;
void LevelTraversal(int root){
	queue<int>Q;
	int count=0;
	Q.push(root);
	while(!Q.empty()){
		int top=Q.front();
		Q.pop();
		count++;
		if(count!=1)printf(" ");
		printf("%d",top);
		if(node[top].left!=-1)Q.push(node[top].left);
		if(node[top].right!=-1)Q.push(node[top].right);
	}
}
void InTraversal(int root){
	if(node[root].left!=-1){
		InTraversal(node[root].left);
	}
	s++;
	if(s!=1)printf(" ");
	printf("%d",root);
	if(node[root].right!=-1){
		InTraversal(node[root].right);	
	}
}
int main(){
	char a,b;
	scanf("%d",&N);
	for(int i=0;i<N;i++){
		getchar(); 	//吸收换行符
		scanf("%c %c",&a,&b);
		if(a=='-')node[i].right=-1;
		else{
			node[i].right=a-'0';
			t[a-'0']=true;
		}
		if(b=='-')node[i].left=-1;
		else{
			node[i].left=b-'0';
			t[b-'0']=true;
		}
	}
	int root;
	for(int i=0;i<N;i++){
		if(!t[i])root=i;	//子树中没有出现过的就是root结点
	}
	LevelTraversal(root);
	printf("\n");
	InTraversal(root);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值