PAT甲级1155

1155 Heap Paths (30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))
One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.
Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.
Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

步骤

  1. 确定树的存储结构
  2. 建树
  3. 深搜输出遍历序列
  4. 判断大小堆

代码

#include <iostream>
#include <stdio.h>
#include <vector>
using namespace std;
struct node
{
    int val;
    node *left,*right;
};
vector<int> v;//存储完全二叉树的层次序列
vector<int> path;//存储遍历路径
int flag=0;//标志变量判断大堆还是小堆
node *build(node *root, int index){
    if(index >= v.size()) return NULL;
    if(root == NULL){
            root = new node();
            root->val = v[index];
            root->left = NULL;
            root->right = NULL;
    }
    root->left = build(root->left, index*2+1 );
    root->right = build(root->right, index*2+2);
    return root;
}
void dfs(node *root,int num){
    if(root == NULL){
        return;
    }
    
     path[num]=root->val;//记录遍历的路径
     
    dfs(root->right, num+1);//遍历右子树并使层次+1
    
    if(root->left == NULL && root->right == NULL){//到达叶子节点
    
        for(int i = 0; i < num+1; i++)//输出该路径
             printf("%d%c",path[i], i != num  ? ' ' : '\n');
       
        for(int j = 1; j < num+1; j++){ //判断该路径是否符合要求
             if(flag == 1 && (path[j-1] < path[j])) flag = 0;
             if(flag == -1 && (path[j-1] > path[j])) flag = 0;
        }
        return;
    }
     dfs(root->left, num+1);//遍历左子树并使层次+1
}
int main(){
    int a;
    scanf("%d", &a);
    v.resize(a);
    path.resize(a);
    for(int i = 0; i < a; i++){
        scanf("%d", &v[i]);
    }
    node *root = NULL;
    root = build( root, 0 );//建树
    if( root->val > root->left->val ) flag = 1;//初步判断是否为大堆
    if( root->val < root->left->val ) flag = -1;//初步判断是否为小堆
    dfs( root , 0 );//深搜遍历并判断
    if(flag == 0) printf("Not Heap\n");
    if(flag == 1) printf("Max Heap\n");
    if(flag == -1) printf("Min Heap\n");
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值