PAT甲级 1155 Heap Paths (30 分)树的遍历

9 篇文章 0 订阅
5 篇文章 0 订阅

问题描述:

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

 题目分析:题目应该不难理解,判定一颗二叉树是否满足堆的条件。我的做法是用DFS模拟树的遍历,搜的时候注意右子树可能会溢出,判定一下即可。

#include <bits/stdc++.h>
using namespace std;
const int N = 1e4+5;
int a[N], p[N];
int n, x, fM, fm;

void DFS(int cur, int x)//用DFS模拟树的遍历 
{
	if(2*x > n)
	{
		printf("%d", p[0]);
		for(int i = 1; i < cur; i++)
		{
			printf(" %d", p[i]);
			if(p[i] > p[i-1])//小顶堆立flag 
				fm = 1;
			else//否则大顶堆立flag 
				fM = 1;
		}	
		puts("");
		return;
	}
	if(2*x+1 <= n)
	{
		p[cur] = a[2*x+1];
		DFS(cur+1, 2*x+1);//优先搜右子树 
	}	
	p[cur] = a[2*x];
	DFS(cur+1, 2*x);//左子树 
}
int main()
{
	cin >> n;
	for(int i = 1; i <= n; i++)
		cin >> a[i];
	p[0] = a[1];
	fM = fm = 0;//判定堆的flag 
	DFS(1, 1);
	if(fM && fm)
		puts("Not Heap");
	else if(fM)
		puts("Max Heap");
	else
		puts("Min Heap");
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值