【PAT】 A1009 Product of Polynomials

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

需要注意的是在value==0时要erase key

#include <iostream>
#include <map>
#include <vector>
using namespace std; 
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
int k_A,k_B;
map<int,double,greater<int>> poly_A,poly_B, poly_out;

void func(){
	map<int,double>::iterator iter_A = poly_A.begin();
	map<int,double>::iterator iter_B = poly_B.begin();
	for(iter_A;iter_A!=poly_A.end();iter_A++){
		for(iter_B = poly_B.begin();iter_B!=poly_B.end();iter_B++){
			double tmp_A_out = iter_A->second*iter_B->second;
			double tmp_K_out = iter_A->first+iter_B->first;
			if (poly_out.count(tmp_K_out)){
				poly_out[tmp_K_out] = tmp_A_out+poly_out[tmp_K_out];
			}else{
				poly_out[tmp_K_out] = tmp_A_out;
			}
            if(poly_out[tmp_K_out]==0){
                poly_out.erase(tmp_K_out);
            }
		}
	}
}

int main(int argc, char** argv) {
	cin>>k_A;
	int tmp_N;
	double tmp_A;
	for(int i=0;i<k_A;i++){
		cin>>tmp_N>>tmp_A;
		poly_A[tmp_N] = tmp_A;
	}	
	cin>>k_B;

	for(int i=0;i<k_B;i++){
		cin>>tmp_N>>tmp_A;
		poly_B[tmp_N] = tmp_A;
	}
	func();
	printf("%d",poly_out.size());
	for(map<int,double>::iterator iter = poly_out.begin();
	iter!=poly_out.end();iter++){
		printf(" %d %.1f",iter->first,iter->second);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值