Rescue bfs典型模板

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison. 

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards. 

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.) 

Input

First line contains two integers stand for N and M. 

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file. 

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 

Sample Input

7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........

Sample Output

13

优先队列记录可以每次走过的路线,并优先弹出最短的路径。

结构体不仅记录每次停留的坐标,还要记录当前所用步数。这样压进优先队列后就可以对步数进行排序。

在数据多的时候,一个字符输入显然是不行的,会超时,可以考虑用scanf("%s"); 一行一行输入。

还有要特别注意的是:***vis[ ][ ]数组用来标记每一个位置是否已经走过,一定要记住!!!***

 

 

#include<bits/stdc++.h>
#include<cstdio>
#include<queue>
using namespace std;
#define MAX 220
int n,m;
struct st{
	int x,y,step;
	friend bool operator <(st a,st b){
		return a.step>b.step;
	}
}a,b; 
char mp[MAX][MAX];
int d[4][2]={-1,0,1,0,0,-1,0,1};
int vis[MAX][MAX];

void bfs(int ox,int oy,int ex,int ey){
	priority_queue<st> que;
	memset(vis,0,sizeof(vis));
	int step=0,ans=-1;
	a.x=ox;a.y=oy;a.step=step;
	que.push(a);
	while(!que.empty()){
		a=que.top();
		que.pop();
		if(mp[a.x][a.y]=='r'){
			ans=a.step;break;
		}
		for(int i=0;i<4;i++){
			b.x=a.x+d[i][0];
			b.y=a.y+d[i][1];
			if(b.x<0||b.y<0||b.x>=n||b.y>=m) continue;
			if(vis[b.x][b.y]==1) continue;
			if(mp[b.x][b.y]=='#') continue;
			if(mp[b.x][b.y]=='x') b.step=a.step+2;
			else b.step=a.step+1;
			que.push(b);
			vis[b.x][b.y]=1;	//记得标记!!! 
		}
	}
	if(ans==-1) puts("Poor ANGEL has to stay in the prison all his life.");
	else cout<<ans<<endl;
}

int main(){
	while(scanf("%d%d",&n,&m)!=EOF){
		int i;
		for(i=0;i<n;++i) scanf("%s",mp[i]);
		int j,ox,oy,ex,ey;
		for(i=0;i<n;++i){
			for(j=0;j<m;++j){
				if(mp[i][j]=='a'){
					ox=i;oy=j;
				}
				if(mp[i][j]=='r'){
					ex=i;ey=j;
				}
			}
		}
		bfs(ox,oy,ex,ey);
	}
	
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值