1004. Bracket Matching

18 篇文章 0 订阅
13 篇文章 0 订阅

Description
检查输入字符串中的括号是否匹配。括号包括:{, }, (, ), [, ].

Input
第一行是一整数,即测试样例个数n.
以下n行,每一行是一个长度不超过100个字符的字符串。

Output
第一行是一整数,即测试样例个数n.
以下n行,每一行是一个长度不超过100的字符串。

Sample Input
Copy sample input to clipboard
3
a
2-[(1+2)*2]
(a+b])
Sample Output
Yes
Yes
No

我的代码

// Problem#: 19145
// Submission#: 4806834
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include <iostream>
#include <stack>
#include <string> 
using namespace std;

int main() {
    int n;
    string temp;
    stack<char> s;
    cin >> n;
    if (n <= 0) return 0;
    while (n--) {
        bool flag = true;
        cin >> temp; 
        for (int i = 0; i < temp.size(); i++) {
            if (temp[i] == '{' || temp[i] == '(' || temp[i] == '[') {
                s.push(temp[i]);
            } else if (temp[i] == '}' || temp[i] == ')' || temp[i] == ']') {
                if (s.empty()) {
                    flag = false;
                    break;
                }
                if ((temp[i] == '}' && s.top() == '{') || 
                    (temp[i] == ')' && s.top() == '(') ||
                    (temp[i] == ']' && s.top() == '[') ) {
                    s.pop();
                } else {
                    flag = false;
                    break;
                }
            }
        } 
        if (!s.empty()) flag = false;
        if (flag == false) cout << "No" << endl;
        else cout << "Yes" << endl;

        temp.clear();
        while (!s.empty()) s.pop();
    }
    return 0;
}                                 
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值