POJ-2492 A Bug's Life (并查集中二分类问题)

A Bug's Life
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 39866 Accepted: 13007

Description

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

Source

TUD Programming Contest 2005, Darmstadt, Germany

#include <cstdio>    
#include <cmath>    
#include <algorithm>   
#include <vector>  
#include <string.h>  
using namespace std;  
int p[100005];  
int findset(int x){  
    return p[x] == x ? x : p[x] = findset(p[x]);  
}   
int main(){  
    int T, u, v, casenum = 1, n, m;  
    scanf("%d", &T);
    while(T--){  
        scanf("%d %d", &n, &m);
        for(int i = 1; i <= n * 2; ++i){
        	p[i] = i;
        }
        int flag = 1;
        for(int i = 1; i <= m; ++i){
        	scanf("%d %d", &u, &v);
       		if(findset(u) == findset(v)){
       			flag = 0;
       		}
       		p[findset(u)] = findset(v + n);
       		p[findset(v)] = findset(u + n);
        }
        printf("Scenario #%d:\n", casenum++);
        if(flag){
        	printf("No suspicious bugs found!\n\n");
        }
        else{
        	printf("Suspicious bugs found!\n\n");
        }
    }  
}  
  
/* 
题意: 
2000个虫子,教授每次会让两只虫子交配,异性才可以交配,同性就错误,问多次实验中有没有错误。 
 
思路: 
这种题出现的两个点是放在不同集合中,和以前放在同一个集合中不一样。一共只有两个集合,我们不妨
对每一个数字设一个对应数,i对应到i+n,那么如果j和i在一个集合就不可以和i+n在一个集合。
每一次出现的两个数i,j,表示i和j不能在一个集合,那么我们让i和j+n在一个集合,j和i+n在一个集合。
然后就按照一般的并查集处理即可。 
*/  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值