A Bug's Life POJ - 2492(种类并查集)

A Bug’s Life POJ - 2492
Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output
The output for every scenario is a line containing “Scenario #i:”, where i is the number of the scenario starting at 1, followed by one line saying either “No suspicious bugs found!” if the experiment is consistent with his assumption about the bugs’ sexual behavior, or “Suspicious bugs found!” if Professor Hopper’s assumption is definitely wrong.
Sample Input
2
3 3
1 2
2 3
1 3
4 2
1 2
3 4
Sample Output
Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!
Hint
Huge input,scanf is recommended.
题意:输出两个虫子的编号,找到是同性的那一组,如果没有就输出异性。将同性的关系标记为0,异性的关系标记为1。与食物链的题和区间奇偶数的题基本完全一样。

 #include<stdio.h>
 #include<stdlib.h>
 #include<string.h>
 int f[1000010],r[1000010];
 void init(int n)
 {
     for(int i=1;i<=n;i++)
     {
         f[i] = i;
         r[i] = 0;
     }
 }
 int getf(int v)
 {
     if(v == f[v])
        return v;
     else
     {
         int t = f[v];
         f[v] = getf(f[v]);
         r[v] = r[v]^r[t];//异或关系,父亲节点跟最新节点是1即是异性,而自己跟父亲节点是0即是同性,那自己跟最新节点就是1即是异性
         return f[v];
     }
 }
 int main()
 {
     int n,i,j;
     int x,y;
     scanf("%d",&n);
     int a,b;
     for(i=1;i<=n;i++)
     {
         int flag = 0;
         scanf("%d %d",&a,&b);
         init(a);
         for(j=0;j<b;j++)
         {
             scanf("%d %d",&x,&y);
             int tx = getf(x);
             int ty = getf(y);
             if(tx == ty)
             {
                 if(r[x] == r[y])//父亲相同,与父亲的亲缘关系相同,则是同性。
                    flag = 1;
             }
             else
             {
                 f[ty] = tx;
                 //r[ty] = !(r[x]^r[y]);
                 r[ty] = (r[x]+r[y]+1)%2;//因为tx!=ty所以新加进来的x,y肯定是异性
                                        //根据偏移分量,rootx ->rooty = rootx->x+x->y+y->rooty
                                        //               = r[x]+d+r[y];(d=0同性,d=1异性)
             }
         }
         if(flag == 1)
            printf("Scenario #%d:\nSuspicious bugs found!\n\n",i);
         else
            printf("Scenario #%d:\nNo suspicious bugs found!\n\n",i);
     }
     return 0;
 }
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值