poj 2239 Selecting Courses 二分图最大匹配数

Selecting Courses
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8174 Accepted: 3625

Description
It is well known that it is not easy to select courses in the college, for there is usually conflict among the time of the courses. Li Ming is a student who loves study every much, and at the beginning of each term, he always wants to select courses as more as possible. Of course there should be no conflict among the courses he selects.

There are 12 classes every day, and 7 days every week. There are hundreds of courses in the college, and teaching a course needs one class each week. To give students more convenience, though teaching a course needs only one class, a course will be taught several times in a week. For example, a course may be taught both at the 7-th class on Tuesday and 12-th class on Wednesday, you should assume that there is no difference between the two classes, and that students can select any class to go. At the different weeks, a student can even go to different class as his wish. Because there are so many courses in the college, selecting courses is not an easy job for Li Ming. As his good friends, can you help him?

Input
The input contains several cases. For each case, the first line contains an integer n (1 <= n <= 300), the number of courses in Li Ming's college. The following n lines represent n different courses. In each line, the first number is an integer t (1 <= t <= 7*12), the different time when students can go to study the course. Then come t pairs of integers p (1 <= p <= 7) and q (1 <= q <= 12), which mean that the course will be taught at the q-th class on the p-th day of a week.

Output
For each test case, output one integer, which is the maximum number of courses Li Ming can select.

Sample Input

5
1 1 1
2 1 1 2 2
1 2 2
2 3 2 3 3
1 3 3

Sample Output

4

===================================================================================

题目大意:每周有7天,每天排12节上课时间。现有若干门课,每门课每周可能有若干个上课时间(每门课每周不管哪一节都上同一课时),问一周内最多能同时上几门课。


解题思路:每门课可以对应若干个上课时间,每个上课时间只可以选择上一门课。课之间没关系,时间之间没关系,可以看做一个二分图。而我们想知道的则是这个二分图的最大匹配数。

//Memory: 648K	Time: 16MS

#include<cstdio>
#include<vector>
using namespace std;
const int MAXC = 300;                                 //最多有300门课
const int T = 7*12;                                   //时间的数量是固定的
int C , linker[T];
bool used[T];
vector<int> g[MAXC];                                  //建立邻接表
//匈牙利算法
bool dfs(int c)
{
    for( int i = 0 ; i < g[c].size() ; i++ )
    {
        int t = g[c][i];
        if( !used[t] )
        {
            used[t] = true;
            if( linker[t] == -1 || dfs(linker[t]) )
            {
                linker[t] = c;
                return true;
            }
        }
    }
    return false;
}

int hungary()
{
    int res = 0;
    for( int i = 0 ; i < T ; i++ )
        linker[i] = -1;
    for( int i = 0 ; i < C ; i++ )
    {
        for( int j = 0 ; j < T ; j++ )
            used[j] = false;
        if( dfs(i) )
            res++;
    }
    return res;
}

int main()
{
    while( ~scanf("%d" , &C ) )
    {
        for( int i = 0 ; i < C ; i++ )           //初始化邻接表
            g[i].clear();
        for( int i = 0 ; i < C ; i++ )
        {
            int t;
            scanf("%d" , &t);
            while(t--)
            {
                int p , q;
                scanf("%d%d" , &p , &q);
                g[i].push_back((p-1)*12+q-1);    //将上课时间编号,从0至7*12-1
            }
        }
        printf("%d\n" , hungary());              //直接使用匈牙利算法
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值