Minimum Inversion Number(线段树求逆序数)

Minimum Inversion Number

题目链接
The inversion number of a given number sequence a1, a2, …, an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.
For a given sequence of numbers a1, a2, …, an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:
a1, a2, …, an-1, an (where m = 0 - the initial seqence)
a2, a3, …, an, a1 (where m = 1)
a3, a4, …, an, a1, a2 (where m = 2)
。。。。
an, a1, a2, …, an-1 (where m = n-1)
You are asked to write a program to find the minimum inversion number out of the above sequences.

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

Output

For each case, output the minimum inversion number on a single line.

Sample Input

10
1 3 6 9 0 8 5 7 4 2

Sample Output

16

题目大意

求逆序数,一个数列的全排列,问其中逆序数最小的情况时多少,逆序数就是数列中每个数字,后面有几个比他小的数字比如,每个逆序数为
1 3 6 9 0 8 5 7 4 2
1 2 4 6 0 4 2 2 1 0
其中6的逆序数为(0,5,4,2)一共4个,所以该数列逆序数为22个

代码实现

#include<iostream>
#include<cstdio>
#include<math.h>
#include<algorithm> 
#include<string>
#include<cstring>
using namespace std;
typedef long long ll;
const int maxn=5e3+5;
struct node {
	int l,r;
	int sum;
}tr[maxn<<2];
int w[maxn];
void up(int u)
{
	tr[u].sum=tr[u<<1].sum+tr[u<<1|1].sum ;
 } 
void build(int u,int l,int r)
{
	tr[u].l=l,tr[u].r=r;
	tr[u].sum=0;
	if(l==r)
	{
		return ;
	}
	else
	{
		int mid=l+r>>1;
		build(u<<1,l,mid);
		build(u<<1|1,mid+1,r);
	 } 
}
void updata(int u,int pos)
{
	if(tr[u].l==tr[u].r&&tr[u].l==pos)	
	{
		tr[u].sum=1;
		 return ;
	} 
	int mid=(tr[u].l+tr[u].r)>>1;
	if(pos<=mid) updata(u<<1,pos);
	else	updata(u<<1|1,pos);
	up(u);
}
int quary(int u,int l,int r)
{
	if(tr[u].l>=l&&tr[u].r<=r)
	{
		return tr[u].sum;
	}
	int mid=tr[u].l+tr[u].r>>1;
	int res=0;
	if(l<=mid) res+=quary(u<<1,l,r);
	if(r>mid)  res+=quary(u<<1|1,l,r);
	return res;
}
int main()
{
	int n;
	while(cin>>n)
	{
		int minn=99999999;
		build(1,0,n-1);
		int ans=0;
		for(int i=0;i<=n-1;i++)
		{
			scanf("%d",&w[i]);
			ans+=quary(1,w[i]+1,n-1);
			updata(1,w[i]);
		}
		minn=min(minn,ans);
		for(int i=0;i<=n-1;i++)
		{
			ans=ans-w[i]+n-w[i]-1;
			minn=min(ans,minn);
		}
		printf("%d\n",minn);
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值