Minimum Inversion Number(树状数组)

Minimum Inversion Number
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21282 Accepted Submission(s): 12760

Problem Description
The inversion number of a given number sequence a1, a2, …, an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, …, an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, …, an-1, an (where m = 0 - the initial seqence)
a2, a3, …, an, a1 (where m = 1)
a3, a4, …, an, a1, a2 (where m = 2)

an, a1, a2, …, an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

Output
For each case, output the minimum inversion number on a single line.

Sample Input

10
1 3 6 9 0 8 5 7 4 2

Sample Output

16

//这道题一开始题意理解错了 后来和同学商量了一下 是我理解有问题
题意是这样的有n个序列
a1a2…….an
a2a3……ana1
..
.
.
.
.
ana1a2…..an-1
问这里面的那个的逆序数最小
这道题就是我之前整理的逆序数的一个变形
其实我们可以这样想 就是我们先求出来第一个的逆序数
那么剩下的逆序数都是有其上一个状态得过来的
如果我们要把a[1]移动到最后面 那么新的序列的逆序数 就是之前的逆序数 + 比a[1]大的个数 (由于a[1]移动到最后面 所以前面所有比a[1]大的都是a[1]的逆序数) - 所有比a[1]小的数(因为 a[1]在没移动之前 是位于序列第一个元素 所以 比a[1]小的数都会差生一个逆序数 这样一来一共会产生a[i] - 1个) 所以通项就是
ans += (n - a[i]) - (a[i] -1 );

#include<iostream>
#include<stdio.h>
#include<string.h>

using namespace std;

int sum[5007],a[5007];
int n;
int lowbit(int x)
{
    return x&(-x);
}
void change(int x,int t)
{
    while(x<=n)
    {
        sum[x] +=t;
        x +=lowbit(x);
    }
}
long long getsum(int x)
{
    long long ans = 0;
    while(x>0)
    {
        ans +=sum[x];
        x -=lowbit(x);
    }
    return ans;
}
int main()
{
    while(~scanf("%d",&n))
    {
        int ans =0;
        memset(sum,0,sizeof(sum));//千万别忘记初始化 我之前忘记初始化 一直WA 加上了才AC
        for(int i = 1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            a[i]++;
            change(a[i],1);
            ans +=(i  - getsum(a[i]));
        }
        long long mn = ans;
        for(int i = 1;i<n;i++)
        {
            ans +=(n - a[i] - (a[i] - 1));
            if(mn >ans) mn = ans;
        }
        printf("%lld\n",mn);
    }
    return 0;
}
  • 3
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值