hdu 1160 FatMouse's Speed(LIS)

Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.

Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],…, m[n] then it must be the case that

W[m[1]] < W[m[2]] < … < W[m[n]]

and

S[m[1]] > S[m[2]] > … > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.

Sample Input
6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900

Sample Output
4
4
5
9
7

题意:给出一些数据,每行数据第一个是体重,第二个是速度,以文件结束符结束输入,求出一组数据,要求是体重增加,速度下降,我们为了更好的输出,我们排序应该逆着来,即按体重减小,速度增加排序,我的是第二种方法用到;
思路;LIS,用pre数组记录路径;
这题我用了两种方法做的,第一种时间复杂度为o(n*n),第二种为o(lon2(n)),应该主要掌握第二种;
代码:
第一种:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node{
  int w,p,i;
}str[10005];
int d[10005],pre[10005];
bool cmp(node a,node b)
{
    if(a.w==b.w)
        return a.p>b.p;
    return a.w<b.w;
}
int main()
{
    int t=0;
    while(~scanf("%d%d",&str[t].w,&str[t].p))
    {
        t++;
        str[t-1].i=t;
    }
    sort(str,str+t,cmp);
    int end,s=0;
    for(int i=0;i<t;i++)
    {
        d[i]=1;
        for(int j=0;j<i;j++)
        {
            if(str[i].w>str[j].w&&str[i].p<str[j].p)
            {
                if(d[i]<d[j]+1)
                {
                    d[i]=d[j]+1;
                    pre[str[i].i]=str[j].i;
                }
            }
        }
        if(s<d[i])
        {
            s=d[i];
            end=str[i].i;
        }
    }
    printf("%d\n",s);
    int tt=0;
    int put[10005];
    while(end)
    {
        put[tt++]=end;
        end=pre[end];
    }
    while(tt--)
    {
        printf("%d\n",put[tt]);
    }
}

第二种:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node{
   int w,p,i;
}str[10005];
struct node1{
   int d,i;
}n[10005];
int len,pre[10005];
bool cmp(node a,node b)
{
    if(a.w==b.w)
        return a.p>b.p;
    return a.w>b.w;
}
int find(int x)
{
    int l=1,r=len,vag;
    while(l<=r)
    {
        int temp=(l+r)/2;
        if(l==r)
            return l;
        else if(x>n[temp].d)
            l=temp+1;
        else
            r=temp;
    }
}
int main()
{
    int t=1;
    while(~scanf("%d%d",&str[t].w,&str[t].p))
    {
        str[t].i=t;
        t++;
    }
    len=1;
    sort(str+1,str+t,cmp);
    memset(n,0,sizeof(n));
    n[1].d=str[1].p;
    int temp;
    int end,s=0;
    for(int i=2;i<t;i++)
    {
        if(str[i].p<n[1].d) temp=1;
        else if(str[i].p>n[len].d)
        {
            len++;
            temp=len;
        }
        else
            temp=find(str[i].p);
        n[temp].d=str[i].p;
        n[temp].i=str[i].i;
        pre[str[i].i]=n[temp-1].i;
        if(s<len)
        {
            end=str[i].i;
            s=len;
        }
    }
    printf("%d\n",len);
    while(end)
    {
        printf("%d\n",end);
        end=pre[end];
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据提供的引用内容,HDU1622是一道关于二叉树的题目,要求读入一系列二叉树的节点信息,输出它们的层序遍历结果。如果输入的二叉树不完整或存在重复节点,则输出"not complete"。下面是Java的实现代码: ```java import java.util.LinkedList; import java.util.Queue; import java.util.Scanner; public class Main { static class Node { int val; Node left, right; public Node(int val) { this.val = val; } } public static void main(String[] args) { Scanner sc = new Scanner(System.in); while (sc.hasNext()) { String s = sc.nextLine(); if (s.isEmpty()) { continue; } String[] nodes = s.split("\\s+"); Node root = new Node(Integer.parseInt(nodes[0].substring(1))); Queue<Node> queue = new LinkedList<>(); queue.offer(root); boolean isComplete = true; for (int i = 1; i < nodes.length - 1; i += 2) { Node cur = queue.poll(); if (!nodes[i].equals("()")) { cur.left = new Node(Integer.parseInt(nodes[i].substring(1))); queue.offer(cur.left); } else { isComplete = false; } if (!nodes[i + 1].equals("()")) { cur.right = new Node(Integer.parseInt(nodes[i + 1].substring(0, nodes[i + 1].length() - 1))); queue.offer(cur.right); } else { isComplete = false; } } if (!isComplete) { System.out.println("not complete"); continue; } StringBuilder sb = new StringBuilder(); queue.offer(root); while (!queue.isEmpty()) { Node cur = queue.poll(); sb.append(cur.val).append(" "); if (cur.left != null) { queue.offer(cur.left); } if (cur.right != null) { queue.offer(cur.right); } } System.out.println(sb.toString().trim()); } } } ```

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值