PKU 1182 食物链 种群并查集

9 篇文章 0 订阅
   食物链
Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 20000/10000K (Java/Other)

Total Submission(s) : 8   Accepted Submission(s) : 2

Problem Description
动物王国中有三类动物A,B,C,这三类动物的食物链构成了有趣的环形。A吃B, B吃C,C吃A。 
现有N个动物,以1-N编号。每个动物都是A,B,C中的一种,但是我们并不知道它到底是哪一种。 
有人用两种说法对这N个动物所构成的食物链关系进行描述: 
第一种说法是"1 X Y",表示X和Y是同类。 
第二种说法是"2 X Y",表示X吃Y。 
此人对N个动物,用上述两种说法,一句接一句地说出K句话,这K句话有的是真的,有的是假的。当一句话满足下列三条之一时,这句话就是假话,否则就是真话。 
1)  当前的话与前面的某些真的话冲突,就是假话; 
2)  当前的话中X或Y比N大,就是假话; 
3)  当前的话表示X吃X,就是假话。 
你的任务是根据给定的N(1 <= N <= 50,000)和K句话(0 <= K <= 100,000),输出假话的总数。 


Input
第一行是两个整数N和K,以一个空格分隔。 <br>以下K行每行是三个正整数 D,X,Y,两数之间用一个空格隔开,其中D表示说法的种类。 <br> 若D=1,则表示X和Y是同类。 <br> 若D=2,则表示X吃Y。


Output
只有一个整数,表示假话的数目。


Sample Input
100 7
1 101 1 
2 1 2
2 2 3 
2 3 3 
1 1 3 
2 3 1 
1 5 5


Sample Output
3


Source
PKU

来源: http://acm.hdu.edu.cn/webcontest/contest_showproblem.php?cid=10969&pid=1004&ojid=1

#include <cstdio>
using namespace std;
#define MAXN 500000+500
struct  LNode
{
    int father; 
    int Relation;   //与父结点的关系,0表示同类,1表示食父,2表示被父食
    int ancestor; 
};
LNode Animals[MAXN];
void Init(int n) 
{
    for (int i = 1;i <= n;i++)
    {
        LNode &Ani = Animals[i];
        Ani.ancestor = Ani.father = i;  //初始化为父节点为自己
        Ani.Relation = 0;               //同类
    }
}
int f(int a,int b)  //Ra->c = f(Ra->b,Rb->c)
{
    if(a==b) return Animals[a].Relation = 0;    //自己必然与自己同类
    else     return Animals[a].Relation = (Animals[a].Relation + f(Animals[a].father,b))%3;
}
int Find(int x)  
{
    LNode &Ani = Animals[x];
    if (Ani.ancestor == x) return x;
    else
    {
        int Real_ance = Find(Ani.ancestor); 
        Ani.ancestor  = Real_ance;  
        Ani.Relation  = f(x,Real_ance);  
        Ani.father = Real_ance;      
        return Ani.ancestor;
    }
}
void Unite(int x,int y,int Rx_y) 
{
    int X = Find(x), Y= Find(y);
    if (X == Y) return;
    LNode &XL = Animals[X];
    XL.father = XL.ancestor = Y;
    int Ry_Y = f(y,Y);
    int RX_x = (3 - f(x,X))%3;
    XL.Relation = (RX_x + (Rx_y + Ry_Y)%3)%3;      

}
bool Judge(int X,int Y,int D)
{
    if(Find(X)!=Find(Y))
    {
        Unite(X,Y,D);
        return false;       //这不是假话
    }
    else
    {
        int anc = Find(X);
        int Rx_anc  = f(X,anc);   
        int Ranc_y  = (3 - f(Y,anc))%3; 
        return (Rx_anc + Ranc_y)%3 != D;//RX->Y = f(RX->anc ,3-RY->anc);
    }
}
int main(void)
{
    //freopen("F:\\test.txt","r",stdin);
    int N,K;
    scanf("%d %d",&N,&K);
    Init(N);int Count = 0;
    for(int i=1,D,X,Y;i<=K;i++)
    {
        scanf("%d %d %d",&D,&X,&Y);
        if(X > N || Y > N)   Count++;
        else if(D == 2 &&X == Y)  Count++;
        else Count+=Judge(X,Y,D-1);
    }
    printf("%d\n",Count);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值