POJ 1703 Find them, Catch them 种群并查集

9 篇文章 0 订阅
   Find them, Catch them
Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 20000/10000K (Java/Other)

Total Submission(s) : 1   Accepted Submission(s) : 1

Problem Description
The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 


Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.


Output
For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."


Sample Input
1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4


Sample Output
Not sure yet.
In different gangs.
In the same gang.


Source
PKU

来源: http://acm.hdu.edu.cn/webcontest/contest_showproblem.php?cid=10969&pid=1000&ojid=1

#include <cstdio>
using namespace std;
#define MAXN 100000+500
struct  LNode
{
    int father;
    int Relation;
    int ancestor;
    int Rank;
};
LNode Animals[MAXN];
void Init(int n)
{
    for (int i = 1;i <= n;i++)
    {
        LNode &Ani = Animals[i];
        Ani.ancestor = Ani.father = i;
        Ani.Rank = 0;
        Ani.Relation = 0;
    }
}
int f(int a,int b)
{
    if(a==b) return Animals[a].Relation = 0;
    else     return Animals[a].Relation = (Animals[a].Relation + f(Animals[a].father,b))%2;
}
int Find(int x)
{
    LNode &Ani = Animals[x];
    if (Ani.ancestor == x) return x;
    else
    {
        int Real_ance = Find(Ani.ancestor);
        Ani.ancestor  = Real_ance;
        Ani.Relation  = f(x,Real_ance);
        Ani.father = Real_ance;
        return Ani.ancestor;
    }
}
void Unite(int x,int y,int Rx_y = 1)
{
    int X = Find(x), Y= Find(y);
    if (X == Y) return;
    LNode &XL = Animals[X];
    XL.father = XL.ancestor = Y;
    int Ry_Y = f(y,Y);
    int RX_x = (2 - f(x,X))%2;
    XL.Relation = (RX_x + (Rx_y + Ry_Y)%2)%2;

}
void Judge(int X,int Y)
{
    if(Find(X)!=Find(Y))    printf("Not sure yet.\n");
    else
    {
        int anc = Find(X);
        int Rx_anc  = f(X,anc);
        int Ranc_y  = (2 - f(Y,anc))%2;
        int D = (Rx_anc + Ranc_y)%2;
        if(!D)   printf("In the same gang.\n");
        else  printf("In different gangs.\n");
    }
}
int main(void)
{
   // freopen("F:\\test.txt","r",stdin);
    int T;scanf("%d",&T);
    char None[200];
    for(int t=1,N,M;t<=T;t++)
    {
        char order;
        scanf("%d %d",&N,&M);
        gets(None);Init(N);
        for(int i=1,a,b;i<=M;i++)
        {
            scanf("%c %d %d",&order,&a,&b);gets(None);
           // printf("%c %d %d\n",order,a,b);
            if(order=='A') Judge(a,b);
            else  Unite(a,b);
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值