hdu 1536 SG函数模板题 千万注意游戏的组合用SG函数值异或 是SG函数的值啊

S-Nim

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3077    Accepted Submission(s): 1361


Problem Description
Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:


  The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.

  The players take turns chosing a heap and removing a positive number of beads from it.

  The first player not able to make a move, loses.


Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:


  Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).

  If the xor-sum is 0, too bad, you will lose.

  Otherwise, move such that the xor-sum becomes 0. This is always possible.


It is quite easy to convince oneself that this works. Consider these facts:

  The player that takes the last bead wins.

  After the winning player's last move the xor-sum will be 0.

  The xor-sum will change after every move.


Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win.

Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?

your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.
 

Input
Input consists of a number of test cases. For each test case: The first line contains a number k (0 < k ≤ 100 describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. The last test case is followed by a 0 on a line of its own.
 

Output
For each position: If the described position is a winning position print a 'W'.If the described position is a losing position print an 'L'. Print a newline after each test case.
 

Sample Input
  
  
2 2 5 3 2 5 12 3 2 4 7 4 2 3 7 12 5 1 2 3 4 5 3 2 5 12 3 2 4 7 4 2 3 7 12 0
 

Sample Output
  
  
LWW WWL
 

Source
 

Recommend
LL
 
题意:
首先输入K 表示一个集合的大小  之后输入集合 表示对于这对石子只能去这个集合中的元素的个数
之后输入 一个m 表示接下来对于这个集合要进行m次询问 
之后m行 每行输入一个n 表示有n个堆  每堆有n1个石子  问这一行所表示的状态是赢还是输 如果赢输入W否则L
 
思路:
对于n堆石子 可以分成n个游戏 之后把n个游戏合起来就好了
 
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
//注意 S数组要按从小到大排序 SG函数要初始化为-1 对于每个集合只需初始化1边
//不需要每求一个数的SG就初始化一边
int SG[10100],n,m,s[102],k;//k是集合s的大小 S[i]是定义的特殊取法规则的数组
int dfs(int x)//求SG[x]模板
{
    if(SG[x]!=-1) return SG[x];
    bool vis[110];
    memset(vis,0,sizeof(vis));

    for(int i=0;i<k;i++)
    {
        if(x>=s[i])
        {
           dfs(x-s[i]);
           vis[SG[x-s[i]]]=1;
         }
    }
    int e;
    for(int i=0;;i++)
      if(!vis[i])
      {
        e=i;
        break;
      }
    return SG[x]=e;
}
int main()
{
    int cas,i;
    while(scanf("%d",&k)!=EOF)
    {
        if(!k) break;
        memset(SG,-1,sizeof(SG));
        for(i=0;i<k;i++) scanf("%d",&s[i]);
        sort(s,s+k);
        scanf("%d",&cas);
        while(cas--)
        {
            int t,sum=0;
            scanf("%d",&t);
            while(t--)
            {
                int num;
                scanf("%d",&num);
                sum^=dfs(num);
               // printf("SG[%d]=%d\n",num,SG[num]);
            }
            if(sum==0) printf("L");
            else printf("W");
        }
        printf("\n");
    }
    return 0;
}



 
 下面是对SG打表的做法
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int K=101;
const int H=10001;//H是我们要打表打到的最大值
int k,m,l,h,s[K],sg[H],mex[K];///k是集合元素的个数 s[]是集合  mex大小大约和集合大小差不多
///注意s的排序
void sprague_grundy()
{
    int i,j;
    sg[0]=0;
    for (i=1;i<H;i++){
        memset(mex,0,sizeof(mex));
        j=1;
        while (j<=k && i>=s[j]){ 
            mex[sg[i-s[j]]]=1;
            j++;
        }
        j=0;
        while (mex[j]) j++;
        sg[i]=j;
    }
}

int main(){
    int tmp,i,j;

    scanf("%d",&k);
    while (k!=0){
        for (i=1;i<=k;i++)
            scanf("%d",&s[i]);
        sort(s+1,s+k+1);            //这个不能少
        sprague_grundy();
        scanf("%d",&m);
        for (i=0;i<m;i++){
            scanf("%d",&l);
            tmp=0;
            for (j=0;j<l;j++){
                scanf("%d",&h);
                tmp=tmp^sg[h];
            }
            if (tmp)
                putchar('W');
            else
                putchar('L');
        }
        putchar('\n');
        scanf("%d",&k);
    }
    return 0;}
 
求SG的模板   注意理解此代码  可以在以后做题中很灵活的应用
//SG 的模板:
int mex1(int p)
{
  int i,t;
  bool vis[101]={0};
  for(i=0;i<n;i++)  //n是S数组的个数
   {
     t=p-S[i];// S[i]是题中定义的特殊取法规则的数组()
     if(t<0)
     break;
     if (f[t]==-1) //f[] 表示存放SG 函数值的数组
      f[t]=mex1(t);
      vis[f[t]]=1;
   }
  for(i=0;;i++)
   {
     if (!vis[i])
     return i;
   }
}
 //注意: S数组要按从小到大排序,注意f和g数组的大小选定

 
 
 
本题另外一种方法 用上面的模板
 
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;
int f[110];
int d[20010];
bool g[110];

int mex1(int p,int k){
    int i,t;
    memset(g,0,sizeof(g));
    for(int i = 0; i < k; i++){
        t = p-f[i];
        if(t < 0) break;
        if(d[t] == -1) d[t] = mex1(t,k);
        g[d[t]] = 1;
    }
    for(i = 0;;i++){
        if(!g[i]) return i;
    }
}

int main(){

   // freopen("1.txt","r",stdin);

    int n,m,k;
    while(scanf("%d",&n)&&n){
        for(int i = 0; i < n; i++)
            scanf("%d",&f[i]);
        sort(f,f+n);
        memset(d,-1,sizeof(d));
        d[0] = 0;
        for(int i = 1; i <= 10003; i++)
            d[i] = mex1(i,n);
        scanf("%d",&m);
        for(int i = 1; i <= m; i++){
            scanf("%d",&k);
            int sum = 0,v;
            for(int j = 1; j <= k; j++){
                scanf("%d",&v);
                sum ^= d[v];
            }
            if(sum == 0) printf("L");
            else printf("W");
        }
        printf("\n");
    }
    return 0;
}




  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值