hdu 1719 博弈水体

Stone Game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 2071    Accepted Submission(s): 576


Problem Description
This game is a two-player game and is played as follows:

1. There are n boxes; each box has its size. The box can hold up to s stones if the size is s.
2. At the beginning of the game, there are some stones in these boxes.
3. The players take turns choosing a box and put a number of stones into the box. The number mustn’t be great than the square of the number of stones before the player adds the stones. For example, the player can add 1 to 9 stones if there are 3 stones in the box. Of course, the total number of stones mustn’t be great than the size of the box.
4.Who can’t add stones any more will loss the game.

Give an Initial state of the game. You are supposed to find whether the first player will win the game if both of the players make the best strategy.
 

Input
The input file contains several test cases.
Each test case begins with an integer N, 0 < N ≤ 50, the number of the boxes.
In the next N line there are two integer si, ci (0 ≤ ci ≤ si ≤ 1,000,000) on each line, as the size of the box is si and there are ci stones in the box.
N = 0 indicates the end of input and should not be processed.
 

Output
For each test case, output the number of the case on the first line, then output “Yes” (without quotes) on the next line if the first player can win the game, otherwise output “No”.
 

Sample Input
  
  
3 2 0 3 3 6 2 2 6 3 6 3 0
 

Sample Output
  
  
Case 1: Yes Case 2: No
题目大意:(取石子游戏)有n个箱子,体积为Si,当前箱子里的石子数为Ci。两个人轮流往箱子里放石子,而且每一次放是数量都有限制,不能超过当前箱子内石子数的平方。例如箱子里有3颗石子,那么下一个人就可以放1~9颗石子,直到箱子被装满。当有一方放不下石子时游戏结束,最后放不下石子的人输。
 
 
思路:
分割成多个小游戏 异或SG函数值
#include<stdio.h>
#include<string.h>
int get_sg(int sz,int ct)
{
    int i;
     for(i=1;i<=1001;i++)
        if(i+i*i>=sz)
        {
           break;
        }
      if(ct==i-1||ct==sz) return 0;
      if(ct>=i) return sz-ct;
      return get_sg(i-1,ct);
}
int main()
{
    int cas,i,j,k=0,n,sum,sz,ct;
    while(scanf("%d",&n)!=EOF)
    {
        if(!n) break;
        sum=0;
        while(n--)
        {
            scanf("%d %d",&sz,&ct);
            if(ct==0||sz==0) continue;
            sum^=get_sg(sz,ct);
        }
        printf("Case %d:\n",++k);
        if(sum!=0) printf("Yes\n");
        else printf("No\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值