PAT 1153 Decode Registration Card of PAT

个人学习记录,代码难免不尽人意。

A registration card number of PAT consists of 4 parts:

the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
the 2nd - 4th digits are the test site number, ranged from 101 to 999;
the 5th - 10th digits give the test date, in the form of yymmdd;
finally the 11th - 13th digits are the testee’s number, ranged from 000 to 999.
Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤10 4 ) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner’s score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.
Output Specification:
For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt’s, or in increasing order of site numbers if there is a tie of Nt.
If the result of a query is empty, simply print NA.

Sample Input:
8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999
Sample Output:
Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

#include<cstdio>
#include<iostream>
#include<vector>
#include<set>
#include<map>
#include<algorithm>
#include<cmath>
using namespace std;
const int maxn=10010;
struct node{
	string str;
	char level;
	int site;
	int date;
	int number;
	int score;
}Node[maxn];
struct newnode{
	int site=-1;
	int count=0;
};
int toint(string s){
	int num=0;
	for(int i=0;i<s.size();i++){
		num=num*10+s[i]-'0';
	}
	return num;
}
bool cmp1(node a,node b){
	if(a.level!=b.level)
	return a.level<b.level;
	else if(a.score!=b.score)
	return a.score>b.score;
	else 
	return a.str<b.str;
}
bool cmp2(newnode a,newnode b){
	if(a.count!=b.count)
	return a.count>b.count;
	else return a.site<b.site;
}
int main(){
   int n,m;
   scanf("%d %d",&n,&m);
   for(int i=0;i<n;i++){
   	 string str;int score;
   	 cin >> str >> score;
   	 Node[i].str=str;
   	 Node[i].level=str[0];
   	 Node[i].site=toint(str.substr(1,3));
   	 Node[i].date=toint(str.substr(4,6));
   	 Node[i].number=toint(str.substr(10,3));
   	 Node[i].score=score;
   }
   for(int i=1;i<=m;i++){
   	int type;
   	scanf("%d",&type);
   	if(type==1){
   		char term;
   		getchar();//必须
   		scanf("%c",&term);
        getchar(); //需要getchar吗? 
   		sort(Node,Node+n,cmp1); 
   		int j=0;
   		for(j;j<n;j++){
   			if(Node[j].level==term){
   				break;
			   }
		   }
		printf("Case %d: %d %c\n",i,type,term);
		if(j==n){
			printf("NA\n");
			continue;
		}
		for(j;j<n;j++){
			if(Node[j].level==term){
				cout << Node[j].str << " " << Node[j].score << endl;
			}
			else break;
		}
	   }
	   else if(type==2){
	   	int site;scanf("%d",&site);
	   	    int total=0,totalscore=0;
	   	    for(int j=0;j<n;j++){
	   	    	if(Node[j].site==site){
	   	    		total++;
	   	    		totalscore+=Node[j].score;
				   }
			   }
			printf("Case %d: %d %d\n",i,type,site);
			if(total==0){
				printf("NA\n");
			continue;
			}
			printf("%d %d\n",total,totalscore);
	   }
	   else{
	   	    int date;
	   	    scanf("%d",&date);
	   	    newnode hashtable[1000];
	   	    bool flag=true;
	   	    for(int j=0;j<n;j++){
	   	    	if(Node[j].date==date){
	   	    		flag=false;
	   	    		hashtable[Node[j].site].site=Node[j].site;
	   	    		hashtable[Node[j].site].count++;
				   }
			   }
			sort(hashtable,hashtable+1000,cmp2);
				printf("Case %d: %d %06d\n",i,type,date);
			if(flag){
				printf("NA\n");
				continue;
			}
			for(int j=0;j<1000;j++){
				if(hashtable[j].site!=-1){
					printf("%d %d\n",hashtable[j].site,hashtable[j].count);
				}
			}
	   }
   }
}

这道题是比较简单中规中矩的结构体存储和排序题,需要注意两点:

  1. type如果是1的话,后面跟着的是个char字符,如果要读取的话需要先getchar掉前面的空格,然后读完之后再getchar一下去掉结尾的换行符
  2. 如果你是用int存储的日期,那么需要在输出的时候补0,否则某些测试点会出错(不显示格式错误),需要注意!
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值