本题要注意一点:17:00:01之前来的人就可以入队,不管什么时候都要处理完,所以时间循环一定要很大
Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.
Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.
Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.
Output Specification:
For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.
Sample Input:7 3 07:55:00 16 17:00:01 2 07:59:59 15 08:01:00 60 08:00:00 30 08:00:02 2 08:03:00 10Sample Output:
8.2
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#include <functional>
#include <numeric>
#include <vector>
#include <list>
#include <map>
#include <string>
#include <queue>
#include <fstream>
using namespace std;
struct Person{
int arriveTime;
int processTime;
int serveTime;
bool operator < (const Person &x){return arriveTime < x.arriveTime;}
Person(int _a , int _p):arriveTime(_a) , processTime(_p){}
};
int getTicks(string _str){
return atoi(_str.substr(0,2).c_str())*3600+atoi(_str.substr(3,2).c_str())*60+atoi(_str.substr(6,2).c_str());
}
int main()
{
int startTime=getTicks("08:00:00");
int endTime=getTicks("25:00:00"); //这个地方的取值要注意,小了的话,最后一个case通过不了
int offDuty=getTicks("17:00:01");
int cnt = 0 , win_num=0;
cin>>cnt>>win_num;
vector<Person> waitingMen;
waitingMen.reserve(cnt);
vector<Person> wins;
vector< vector<Person> > queues;
queues.resize(win_num);
for(int i=0;i<cnt;i++){
string _time;
int _processTime;
cin>>_time>>_processTime;
int _ticks=getTicks(_time);
if(_ticks < offDuty )waitingMen.push_back(Person( _ticks , _processTime*60));
}
sort(waitingMen.begin(),waitingMen.end());
int totalWaitingTime=0;
int totalWaitingMen=0;
for( int curTime=startTime ; curTime<endTime ; curTime++){
for(int i=0 ; i<win_num ; i++){
if( !queues[i].empty() && (curTime == queues[i].front().serveTime + queues[i].front().processTime) )
queues[i].erase( queues[i].begin() );
}
for(int i=0 ; i<win_num ; i++){
if(queues[i].empty() && !waitingMen.empty() && curTime>=waitingMen.front().arriveTime ){
waitingMen.front().serveTime=curTime;
totalWaitingTime+=(curTime-waitingMen.front().arriveTime);
totalWaitingMen+=1;
queues[i].push_back(waitingMen.front());
waitingMen.erase(waitingMen.begin());
}
}
}
if(totalWaitingMen==0)printf("0.0");
else printf("%.1f",1.0*totalWaitingTime/totalWaitingMen/60.0);
return 0;
}