hdu 逃离迷宫

14 篇文章 0 订阅

Problem Description
  给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗? Input
  第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,
  第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符'.'表示该位置为空地,字符'*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x1, y1, x2, y2 (1 ≤ k ≤ 10, 1 ≤ x1, x2 ≤ n, 1 ≤ y1, y2 ≤ m),其中k表示gloria最多能转的弯数,(x1, y1), (x2, y2)表示两个位置,其中x1,x2对应列,y1, y2对应行。
Output
  每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。 Sample Input
2
5 5
...**
*.**.
.....
.....
*....
1 1 1 1 3
5 5
...**
*.**.
.....
.....
*....
2 1 1 1 3
Sample Output
no
yesSource
“网新恩普杯”杭州电子科技大学程序设计邀请赛
--------------------------------------------------------------------------------

#include<cstdio>
#include<queue>
#include<string.h>
#include<iostream>
using namespace std;
int dy[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
char ss[110][110];
int vis[110][110];
int n;
int r,l;
int round;
struct node
{
    int x;
    int y;
    int turn;
};
bool cango(int x,int y)
{
    if(1<=x&&x<=r&&y>=1&&y<=l&&ss[x][y]=='.')
       return true;
    return false;
}
void bfs(node s1,node s2)
{
   queue<node>q;
   node st,ed;
   int i,nextx,nexty;
   memset(vis,0,sizeof(vis));
   st.x=s1.x;
   st.y=s1.y;
   st.turn=-1;
   q.push(st);
   while(!q.empty())
   {
       st=q.front();
       q.pop();
       for(i=0;i<4;i++)  //开始各个方向
       {
           nextx=st.x+dy[i][0];
           nexty=st.y+dy[i][1];
           while(cango(nextx,nexty))
           {
               if(!vis[nextx][nexty])
               {
                   vis[nextx][nexty]=true;
                   ed.x=nextx;
                   ed.y=nexty;
                   ed.turn=st.turn+1;  //到这里代表此处在这条路线上已经走过的弯
                   if(ed.x==s2.x&&ed.y==s2.y&&ed.turn<=round)
                   {
                       printf("yes\n");
                       return ;
                   }
                q.push(ed);
               }
             nextx+=dy[i][0];//沿该方向一直走下去 
             nexty+=dy[i][1];
           }

       }
   }
   printf("no\n");
   return ;
}
int main()
{
    int i,j;
    node s1,s2;
    scanf("%d",&n);
    while(n--)
    {
      memset(ss,0,sizeof(ss));
      scanf("%d%d",&r,&l);
      for(i=1;i<=r;i++)
        for(j=1;j<=l;j++)
          cin>>ss[i][j];
      cin>>round>>s1.y>>s1.x>>s2.y>>s2.x;//注意先输入的书列,后输入的是行 
     // cout<<round<<s1.x<<s1.y<<s2.x<<s2.y;
       if(s1.x==s2.x&&s1.y==s2.y)
           printf("yes\n");
       else
          bfs(s1,s2);
    }
  return 0;
}


 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值