hdu Sumsets

22 篇文章 0 订阅



Sumsets

Time Limit : 6000/2000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 20   Accepted Submission(s) : 14
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

Source

USACO 2005 January Silver


解题报告:

     题目大意就是将一个整数拆分为只有 1 或者 有 1 和偶数组分的几个数的和;

例如 :整数 7;

 

进过分析可得出:

                                                                                                                                   结论是:当整数n为奇数时,相当于在f[n-1]的拆分结果上增加一个 1 即可;

               当整数n为偶数时,分为两种情况,含有1 ,和不含有1;

                           含有1时,就是f[n-1],不含1时,就是f[n/2](拆分结果都除以2)的结果              

                         综上结果,得出打表公式:

                                    f[1]=1;   f[2]=2;

                                    f[n]=f[n-1]              //n是奇数

                                    f[n]=f[n-1]+f[n/2]   //n是偶数

     


#include<stdio.h>
#include<string.h>
__int64 f[1000010];
int main()
{
	int i,j;
	int n;
	f[1]=1;
	f[2]=2;
	for(i=3;i<=1000000;i++)
	{
		if((i&1)==0)//i是偶数
		{
			f[i]=(f[i-1]+f[i/2])%1000000000; 
		} 
		else
		{
			f[i]=f[i-1]%1000000000;//应题目要求,最多输出九位数, 
		}
	}
	while(scanf("%d",&n)!=EOF)
	{
		printf("%d\n",f[n]);
	}
return 0;
} 



Sumsets

Time Limit : 6000/2000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 20   Accepted Submission(s) : 14
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

Source

USACO 2005 January Silver


解题报告:

     题目大意就是将一个整数拆分为只有 1 或者 有 1 和偶数组分的几个数的和;

例如 :整数 7;

 

进过分析可得出:

                                                                                                                                   结论是:当整数n为奇数时,相当于在f[n-1]的拆分结果上增加一个 1 即可;

               当整数n为偶数时,分为两种情况,含有1 ,和不含有1;

                           含有1时,就是f[n-1],不含1时,就是f[n/2](拆分结果都除以2)的结果              

                         综上结果,得出打表公式:

                                    f[1]=1;   f[2]=2;

                                    f[n]=f[n-1]              //n是奇数

                                    f[n]=f[n-1]+f[n/2]   //n是偶数

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值