ACM: uva 10125 - Sumsets

Sumsets

 

Description

Given S, a set of integers, find the largest d such that a + b + c = d where a, b, c, and d are distinct elements of S.

 

                            ACM: <wbr>uva <wbr>10125 <wbr>- <wbr>Sumsets 

Input

Several S, each consisting of a line containing an integer 1 <= n <= 1000 indicating the number of elements in S, followed by the elements of S, one per line. Each element of S is a distinct integer between -536870912 and +536870911 inclusive. The last line of input contains 0.

Output

For each S, a single line containing d, or a single line containing "no solution".

Sample Input

5

2 3 5 7 12

5

2 16 64 256 1024

0

Sample Output

12

no solution

 

题意: 在N个数的整数集合里面找出四个数, 满足a+b+c = d, 输出d, 否则输出 "no solution"

 

解题思路:

    1. 枚举即可.

 

 

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
#define MAX 1005

int n;
int a[MAX];

int main()
{
// freopen("input.txt", "r", stdin);
 int i, j, l, r, temp;
 while(scanf("%d", &n) != EOF)
 {
  if(n == 0) break;
  for(i = 0; i < n; ++i)
   scanf("%d", &a[i]);

  sort(a, a+n);
  bool flag = false;
  int ans;
  for(i = n-1; i >= 0; --i)
  {
   for(j = n-1; j >= 0; --j)
   {
    if(i != j)
    {
     temp = a[i]-a[j];
     for(l = 0, r = j-1; l < r; )
     {
      if(a[l]+a[r] == temp)
      {
       ans = a[i];
       flag = true;
       break;
      }
      if(a[l]+a[r] > temp) r--;
      else l++;
     }
     if(flag) break;
    }
   }
   if(flag) break;
  }

  if(flag) printf("%d\n", ans);
  else printf("no solution\n");
 }
 return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值