HDU 2717--Catch That Cow【BFS】

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8103    Accepted Submission(s): 2568


Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
  
  
5 17
 

Sample Output
  
  
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
 

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;

int vis[100100];

struct node {
	int v,t;
};

int n,m;
int check(int x){
    if(x<0 || x>100000) return 0;//以为这样判定会超时,没想到过了
    if(vis[x]) return 0;
    return 1;
}
int bfs(){
	memset(vis,0,sizeof(vis));
	queue<node>q;
	node st,s1,s2,s3;
	st.v=n;
	st.t=0;
	vis[n]=1;
	q.push(st);
	while(!q.empty()){
		 st=q.front();
		 q.pop();
		if(st.v==m) return st.t;
		s1.v=st.v*2;
		if(check(s1.v)){
            vis[s1.v]=1; s1.t=st.t+1; q.push(s1);
		}
		s2.v=st.v+1;
		if(check(s2.v)){
			vis[s2.v]=1; s2.t=st.t+1; q.push(s2);
		}
		s3.v=st.v-1;
		if(check(s3.v)){
			vis[s3.v]=1; s3.t=st.t+1; q.push(s3);
		}
	}
}

int main (){
	while(scanf("%d%d",&n,&m)!=EOF){
	printf("%d\n",bfs());
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值