HDU2717 Catch That Cow

Catch That Cow

                                                       Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


                                                       Total Submission(s): 13999    Accepted Submission(s): 4286


Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
  
  
5 17
 

Sample Output
  
  
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
 

Source

大意就是农夫约翰在某个位置,并且他被告诉了牛的位置,他们所处的位置就相当于在一条直线上的不同位置。现在我们需要给出农夫抓到牛最少需要多长时间?
农夫有以下两种移动方式:
1.如果农夫在X点,那么农夫可以到X-1点或X+1点,花费时间一分钟
2.如果农夫在X点,那么农夫可以到2X点,花费一分钟

思路:求最小时间,广搜。但这个是一维的搜索问题,数据的处理不太一样。
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
int vis[100005];
int di[3]={1,1,2};
int dir[3]={-1,1,0};
int n,k;
int tt=32767;
struct node
{
    int x;
    int time;
}pre,now;
void bfs()
{
    int i;
    queue<node>q;
    pre.time=0;
    q.push(pre);
    vis[pre.x]=1;
    while(!q.empty())
    {
        now=q.front();
        q.pop();
        if(now.x==k)
        {
            cout<<now.time<<endl;
            return ;
        }
        for(i=0;i<3;i++)
        {
            pre.x=now.x*di[i]+dir[i];//一维与二维的不同之处
            pre.time=now.time+1;
            if(pre.x>=0&&pre.x<=100000&&vis[pre.x]==0)//pre.x的边界问题第一次没有考虑,runtime error
            {
                vis[pre.x]=vis[pre.x]+1;
                q.push(pre);
            }
            else
                continue;
        }
    }
}
int main()
{
    while(cin>>n>>k)
    {
        int i,j;
        memset(vis,0,sizeof(vis));
        pre.x=n;
        bfs();
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值