hdu2717 catch that cow【BFS】

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9364    Accepted Submission(s): 2936


Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
  
  
5 17
 

Sample Output
  
  
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
 
【代码】
#include<stdio.h>
#include<string.h>
#include<queue>
#define maxn 100100
using namespace std;
int n,k;
int map[maxn];
struct node {
	int x,step;
} a,b; //b表示下一步
int check(int x) {
	if(x<0||x>100000||map[x])
		return 0;
	return 1;
}
int bfs(int x) {
	int i;
	queue<node> q;
	//node a,next;
	a.x=x;
	a.step=0;
	map[x]=1;
	q.push(a);
	while(!q.empty()) {
		a=q.front();
		q.pop();
		if(a.x==k)
			return a.step;
		b=a;
		b.x=a.x+1;
		if(check(b.x)) {
			b.step=a.step+1;
			map[b.x]=1;
			q.push(b);
		}
		b.x=a.x-1;
		if(check(b.x)) {
			b.step=a.step+1;
			map[b.x]=1;
			q.push(b);
		}
		b.x=2*a.x;
		if(check(b.x)) {
			b.step=a.step+1;
			map[b.x]=1;
			q.push(b);
		}
	}
}
int main() {
	int ans;
	while(scanf("%d%d",&n,&k)!=EOF) {
		memset(map,0,sizeof(map));
		ans=bfs(n);
		printf("%d\n",ans);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值