lightoj1297(二分查找,或求导)

16 篇文章 0 订阅
2 篇文章 0 订阅

lightoj1297(二分查找,或求导)


Submit Status Practice LightOJ 1297
Description
In the following figure you can see a rectangular card. The width of the card is W and length of the card is L and thickness is zero. Four(x*x) squares are cut from the four corners of the card shown by the black dotted lines. Then the card is folded along the magenta lines to make a box without a cover.

Given the width and height of the box, you will have to find the maximum volume of the box you can make for any value ofx.
Input
Input starts with an integer T (≤ 10000), denoting the number of test cases.
Each case starts with a line containing two real numbers L and W (0 < L, W < 100).
Output
For each case, print the case number and the maximum volume of the box that can be made. Errors less than10-6 will be ignored.
Sample Input
3
2 10
3.590 2.719
8.1991 7.189
Sample Output
Case 1: 4.513804324
Case 2: 2.2268848896
Case 3: 33.412886

My solution:
/*2015.11.10*/
1.求导:(找到最大值处X的值)
此题x的解为:x=(-b-sqrt(b*b-4*a*c)/(2*a)
#include<stdio.h>
#include<math.h>
int main()
{
	int i=0,j,n;
	double t,a,b,ans;
	scanf("%d",&n);
	while(n--)
	{
		i++;
		scanf("%lf%lf",&a,&b);
		t=16*(a+b)*(a+b)-48*a*b;//deta的值 
		ans=(4*(a+b)-sqrt(t))/24;
		ans=(a-2*ans)*(b-2*ans)*ans;
		printf("Case %d: %.7lf\n",i,ans);
	}
	return 0;
}

2.二分查找,根据deta在最大值x附近处,x左边deta的大于0,右边的小于0。
#include<stdio.h>
double l=0,r,mid,a,b;
int deta(double x)
{
	double ant;
	ant=12*x*x-4*a*x-4*b*x+a*b;
	if(ant>0)
	return 1;
	return 0;
}
void jie()
{
	while(r-l>10e-10)
	{
		mid=(l+r)/2;
		if(deta(mid))
		l=mid;
		else
		r=mid;
	}
}
int main()
{
	int t,i=0;
	double ans;
	scanf("%d",&t);
	while(t--)
	{
		i++;l=0;
		scanf("%lf%lf",&a,&b);
		r=a<b?a:b;/*  2*x必定小于最小边,选择x作为限定条件*/
		r=r/2;
		jie();
		ans=(a-2*mid)*(b-2*mid)*mid;
		printf("Case %d: %.10lf\n",i,ans);
	 } 
	return 0;
 } 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值