LightOJ 1297

 LightOJ 1297 

Time Limit: 2000MS      Memory Limit: 32768KB      64bit IO Format: %lld & %llu

Description

In the following figure you can see a rectangular card. The width of the card is W and length of the card is L and thickness is zero. Four (x*x) squares are cut from the four corners of the card shown by the black dotted lines. Then the card is folded along the magenta lines to make a box without a cover.


Given the width and height of the box, you will have to find the maximum volume of the box you can make for any value of x.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing two real numbers L and W (0 < L, W < 100).

Output

For each case, print the case number and the maximum volume of the box that can be made. Errors less than 10-6 will be ignored.

Sample Input

3

2 10

3.590 2.719

8.1991 7.189

Sample Output

Case 1: 4.513804324

Case 2: 2.2268848896

Case 3: 33.412886

题意:在矩形的四个角割掉四个边长为X的小正方形,求出剩下的部分折成的无顶长方体or(正方体)的体积最大为???

    思路:V=x*(w-2*x)*(l-2x) ,然后对其进行求导得到变化趋势,再用二分求得最大值!

 代码:

      

#include<stdio.h>
#include<string.h>
double w,l;
double min(double x,double y)
{
	if(x>y)
	return y;
	return  x;
}
double  js(double  x)
{
	return  x*(w-2*x)*(l-2*x);//体积的计算! 
}
double  jsd(double  x)
{
	return (w-2*x)*(l-2*x)-2*x*(l-2*x)-2*x*(w-2*x);//倒数! 
}
int main()
{
	int t,mark=1;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lf%lf",&w,&l);
		double  left=0.0,right=min(w,l),mid;
		while(right-left>=0.00000001)//二分 
		{
			 mid=(left+right)/2;
			double  count=jsd(mid);
			if(count>0)//在递增的区间倒数大于零! 
			left=mid;
			else
			right=mid;
		}
		printf("Case %d: %.6lf\n",mark++,js(mid));
	}
	return  0;
}

    

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值