FOJ-2214 Knapsack problem

FOJ-2214 Knapsack problem

Problem Description

Given a set of n items, each with a weight w[i] and a value v[i],determine a way to choose the items into a knapsack so that the total weight isless than or equal to a given limit B and the total value is as large aspossible. Find the maximum total value. (Note that each item can be only chosenonce).

Input

The first line contains the integer T indicating to the number of testcases.

For each test case, the first line contains the integers n and B.

Following n lines provide the information of each item.

The i-th line contains the weight w[i] and the value v[i] of the i-th itemrespectively.

1 <= number of test cases <= 100

1 <= n <= 500

1 <= B, w[i] <= 1000000000

1 <= v[1]+v[2]+...+v[n] <= 5000

All the inputs are integers.

Output

For each test case, output the maximum value.

Sample Input

1

5 15

12 4

2 2

1 1

4 10

1 2

Sample Output

15

 

注:按照01背包的正常思路来做,f数组的规模太大,即;f[1000000000]会超内存,同时在填充背包时由于背包容量太大,循环时可能会超时。观察题目发现,如果从背包所能装的最大物品价值考虑时,此时f数组规模就比较小了,f[5050]就够了(1 <= v[1]+v[2]+...+v[n] <= 5000),此时就用到逆01背包。

My  solution:

/*2016.3.1*/

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
long long f[5050],w[550],v[550];
//int f[5050],w[550],v[550];由于B~1000000000,经过累加后f数组会超出int范围,所以f数组需定义为长整形。由于用到 min()函数,比较的两个对象必须是同种数据类型,因此把w[]、v[]也定义为长整形 
int main()
{
	int  i,j,k,n,m,sum;
	scanf("%d",&k);
	while(k--)
    {
    	sum=0;
    	memset(f,0,sizeof(f));
    	scanf("%d%d",&n,&m);
    	for(i=1;i<=n;i++)
    	{
    		scanf("%d%d",&w[i],&v[i]);
    		sum+=v[i];
		}
    	for(i=1;i<=n;i++)
    	for(j=sum;j>=v[i];j--)
    	{
    		if(f[j-v[i]]!=0)
    		{
    			if(f[j]!=0)
    			f[j]=min(f[j],f[j-v[i]]+w[i]);
    			else
    			f[j]=f[j-v[i]]+w[i];
			}
			else  
			{
				if(j==v[i])
				{
					if(f[j]!=0)
				 	  f[j]=min(f[j],w[i]);
					else
					  f[j]=w[i];
				}
			}
		}
		for(j=sum;j>0;j--)
		if(f[j]<=m&&f[j])
		break;
		printf("%d\n",j);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值