FOJ2214 Knapsack problem(逆01背包)


Link:http://acm.fzu.edu.cn/problem.php?pid=2214


Problem 2214 Knapsack problem

Accept: 742    Submit: 2812
Time Limit: 3000 mSec    Memory Limit : 32768 KB

 Problem Description

Given a set of n items, each with a weight w[i] and a value v[i], determine a way to choose the items into a knapsack so that the total weight is less than or equal to a given limit B and the total value is as large as possible. Find the maximum total value. (Note that each item can be only chosen once).

 Input

The first line contains the integer T indicating to the number of test cases.

For each test case, the first line contains the integers n and B.

Following n lines provide the information of each item.

The i-th line contains the weight w[i] and the value v[i] of the i-th item respectively.

1 <= number of test cases <= 100

1 <= n <= 500

1 <= B, w[i] <= 1000000000

1 <= v[1]+v[2]+...+v[n] <= 5000

All the inputs are integers.

 Output

For each test case, output the maximum value.

 Sample Input

15 1512 42 21 14 101 2

 Sample Output

15

 Source

第六届福建省大学生程序设计竞赛-重现赛(感谢承办方华侨大学)



AC code:

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<math.h>
#include<string.h>
#include<map>
#include<set>
#include<vector>
#define LL long long
#define INF 0xffffffff
#define PI acos(-1)
#define EPS 1e-6
using namespace std;

int n;

//逆01背包公式:dp[v]=min(dp[v],dp[v-val[i]]+wei[i]); 
LL B,sum;
LL wei[555],val[555],dp[5050];

int main()
{
//	freopen("in.txt","r",stdin);
	int t,i,j;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%lld",&n,&B);
		sum=0;
		for(i=1;i<=n;i++)
		{
			scanf("%lld %lld",&wei[i],&val[i]);
			sum+=val[i];
		}
		for(i=0;i<=sum;i++)
		{
			dp[i]=INF;
		}
		dp[0]=0;
		for(i=1;i<=n;i++)
		{
			for(j=sum;j>=val[i];j--)
			{
				dp[j]=min(dp[j],dp[j-val[i]]+wei[i]);
			}
		}
		for(i=sum;i>=0;i--)
		{
			if(dp[i]<=B)
			{
				printf("%d\n",i);
				break;
			}
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值