F - What Is Your Grade?

点击打开链接




“Point, point, life of student!” 
This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course. 
There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only when your rank is in the first half of all students who solve 4 problems). Analogically(以此类推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50. 
Note, only 1 student will get the score 95 when 3 students have solved 4 problems. 
I wish you all can pass the exam! 
Come on! 
Input
Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed time). You can assume that all data are different when 0<p. 
A test case starting with a negative integer terminates the input and this test case should not to be processed. 
Output
Output the scores of N students in N lines for each case, and there is a blank line after each case. 
Sample Input
4
5 06:30:17
4 07:31:27
4 08:12:12
4 05:23:13
1
5 06:30:17
-1
Sample Output
100
90
90
95

100



分析:

题目的意思是像95的给法首先前提必须是做了4题,此外用时还必须最少(假设有2或3人) ,若是有4或5个人则得到95的必定是2人;



代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
struct student
{
int num;
int s;
int fen;
int id;
}p[100];
int arr[6];
bool cmp1(student a,student b)
{if(a.num==b.num)
return a.s<b.s;
return a.num>b.num;
}
bool cmp2(student a,student b)
{
return a.id<b.id ;
}
int main()
{int n,h,m,s,num;
while(scanf("%d",&n)==1&&n>0)
{
for(int i=1;i<6;i++)
arr[i]=0;
for(int i=0;i<n;i++)
{
scanf("%d %d:%d:%d", &num, &h, &m, &s);
p[i].s=m * 60 + h * 3600+s;
p[i].id =i;
p[i].num =num;
p[i].fen =100-(5-num)*10;
arr[num]++;
}
sort(p,p+n,cmp1);

for(int i=4,id=0;i;i--)
{if(arr[i])
while(p[id].num !=i)
id++;
if(arr[i]==1)
p[id++].fen +=5;
for(int j=0;j<arr[i]/2;j++)
p[id++].fen +=5;
}
sort(p, p+ n, cmp2);
for(int i = 0; i < n; ++i)
printf("%d\n", p[i].fen );
printf("\n");
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
`integrate-series-tail` is a function used in the definition of stream-based power series expansions. It takes a stream representing the coefficients of a power series, and returns a new stream representing the coefficients of the antiderivative of that series. Here's the definition of `integrate-series-tail`: ``` (define (integrate-series-tail s) (stream-cons 0 (add-series-tail (scale-series-tail s 1/2) (integrate-series-tail (stream-cdr s))))) ``` The function first creates a new stream with a leading coefficient of 0, since the antiderivative of a power series has no constant term. It then uses two other functions, `add-series-tail` and `scale-series-tail`, to combine and manipulate the coefficients of the input stream. `add-series-tail` takes two streams representing power series, and returns a new stream representing the sum of those series. `scale-series-tail` takes a stream representing a power series, and a scalar value, and returns a new stream representing the series with each coefficient multiplied by that scalar. In the definition of `integrate-series-tail`, we use `scale-series-tail` to multiply the input stream by `1/2`, since the antiderivative of a power series is obtained by dividing each coefficient of the original series by the corresponding power of the variable. We then use `add-series-tail` to combine this scaled stream with the recursively computed antiderivative of the tail of the input stream. This recursive computation of the antiderivative of the tail of the input stream is what allows us to generate the coefficients of the power series for the antiderivative. By repeatedly integrating the series, we can generate the coefficients of the power series for any number of antiderivatives of the original function.

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值