Red and Black (dfs)【HDU】-1312

点击打开链接


Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21128    Accepted Submission(s): 12877


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13
 

Source


题意:找@附近的   ’ .‘  的个数包括@自身所在的点,遇到 ' #' (墙)停止,

解析:运用dfs或bfs进行查找


代码如下:

#include <cstdio>
#include <queue>
#include <cstring>
#include <algorithm>
using namespace std;
char map[22][22];
int move_x[4]={0,0,-1,1};
int move_y[4]={1,-1,0,0};          
int x,y,stp;
int m,n;
bool check(int x,int y)           //判断是否越界或遇到墙 
{
	if(x<0||x>=m||y<0||y>=n||map[x][y]=='#')
	return false;
	return true;
}
bool dfs(int x,int y)            //查找上下左右四个方向是否有  '.'  
{
	
	stp++;
	map[x][y]='#';
	for(int i=0;i<4;i++)
	{
		if(check(x+move_x[i],y+move_y[i]))
		{
			if(dfs(x+move_x[i],y+move_y[i]))
			return true;
		}
	}
	return false;
}
int main()
{
	while(scanf("%d%d",&n,&m)&&(m||n))
	{
		for(int i=0;i<m;i++)
		scanf("%s",map[i]);
		for(int i=0;i<m;i++)
		{
			for(int j=0;j<n;j++)
			{
				if(map[i][j]=='@')
				{
					x=i;y=j;
				}
			}
		}
		stp=0;
		dfs(x,y);
		printf("%d\n",stp);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值