HDU 4417 Super Mario

Super Mario

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2213    Accepted Submission(s): 1072


Problem Description
Mario is world-famous plumber. His “burly” figure and amazing jumping ability reminded in our memory. Now the poor princess is in trouble again and Mario needs to save his lover. We regard the road to the boss’s castle as a line (the length is n), on every integer point i there is a brick on height hi. Now the question is how many bricks in [L, R] Mario can hit if the maximal height he can jump is H.
 

Input
The first line follows an integer T, the number of test data.
For each test data:
The first line contains two integers n, m (1 <= n <=10^5, 1 <= m <= 10^5), n is the length of the road, m is the number of queries.
Next line contains n integers, the height of each brick, the range is [0, 1000000000].
Next m lines, each line contains three integers L, R,H.( 0 <= L <= R < n 0 <= H <= 1000000000.)
 

Output
For each case, output "Case X: " (X is the case number starting from 1) followed by m lines, each line contains an integer. The ith integer is the number of bricks Mario can hit for the ith query.
 

Sample Input
  
  
1 10 10 0 5 2 7 5 4 3 8 7 7 2 8 6 3 5 0 1 3 1 1 9 4 0 1 0 3 5 5 5 5 1 4 6 3 1 5 7 5 7 3
 

Sample Output
  
  
Case 1: 4 0 0 3 1 2 0 1 5 1
 

Source

解题思路:划分树+二分或者离线树状数组或者树套树(这个不会)

离线树状数组
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define lowbit(x) (x&(-x))
#define Maxn 100010
using namespace std;
int tree[Maxn],b[Maxn];
struct Q
{
	int s,e,x;
	int id;
	friend bool operator <(Q a,Q b)
	{
		return a.x<b.x;
	}
}q[Maxn];
struct Arr
{
	int x;
	int id;
	friend bool operator <(Arr a,Arr b)
	{
		if(a.x!=b.x)
		    return a.x<b.x;
		else
			return a.id<b.id;
	}
}a[Maxn];
void add(int pos,int n)
{
	for(int i=pos;i<=n;i+=lowbit(i))
		tree[i]++;
}
int sum(int pos)
{
	int ans=0;
	for(int i=pos;i>0;i-=lowbit(i))
		ans+=tree[i];
	return ans;
}
int main()
{
	int t,n,m,ncase=1;
	int ans[Maxn];
	freopen("in.txt","r",stdin);
	freopen("out.txt","w",stdout);
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		memset(tree,0,sizeof(tree));
		memset(ans,0,sizeof(ans));
		for(int i=1;i<=n;i++)
			scanf("%d",&a[i].x),a[i].id=i;
		sort(a+1,a+n+1);
		for(int i=0;i<m;i++)
		{
			scanf("%d%d%d",&q[i].s,&q[i].e,&q[i].x),q[i].id=i;
			q[i].s++,q[i].e++;
		}
		sort(q,q+m);
		int p=1;
		for(int i=0;i<m;i++)
		{
			while(a[p].x<=q[i].x&&p<=n)
				add(a[p].id,n),p++;
			ans[q[i].id]=sum(q[i].e)-sum(q[i].s-1);
		}
		printf("Case %d:\n",ncase++);
		for(int i=0;i<m;i++)
			printf("%d\n",ans[i]);
	}
	return 0;
}

划分树+二分:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int Maxn=100010;
int tree[20][Maxn];
int sorted[Maxn];
int toleft[20][Maxn];
int n;
void build(int l,int r,int dep)
{
	if(l==r)
		return ;
	int mid=(l+r)>>1;
	int same=mid-l+1;
	for(int i=l;i<=r;i++)
		if(tree[dep][i]<sorted[mid])
			same--;
	int lpos=l;
	int rpos=mid+1;
	for(int i=l;i<=r;i++)
	{
		if(tree[dep][i]<sorted[mid])
			tree[dep+1][lpos++]=tree[dep][i];
		else if(tree[dep][i]==sorted[mid]&&same>0)
			tree[dep+1][lpos++]=tree[dep][i],same--;
		else
			tree[dep+1][rpos++]=tree[dep][i];
		toleft[dep][i]=toleft[dep][l-1]+lpos-l;
	}
	build(l,mid,dep+1);
	build(mid+1,r,dep+1);
}
int query(int L,int R,int l,int r,int dep,int k)
{
	if(l==r)
		return tree[dep][l];
	int mid=(L+R)>>1;
	int cnt=toleft[dep][r]-toleft[dep][l-1];
	if(cnt>=k)
	{
		int newl=L+toleft[dep][l-1]-toleft[dep][L-1];
		int newr=newl+cnt-1;
		return query(L,mid,newl,newr,dep+1,k);
	}
	else
	{
		int newr=r+toleft[dep][R]-toleft[dep][r];
		int newl=newr-(r-l-cnt);
		return query(mid+1,R,newl,newr,dep+1,k-cnt);
	}
}
int solve(int a,int b,int c)
{
	int l=1,r=1+b-a;
	int ans=0;
	while(r>=l)
	{
		int m=(l+r)>>1;
		int tmp=query(1,n,a,b,0,m);
		if(tmp>c)
			r=m-1;
		else 
		{
			l=m+1;
			ans=m;
		}
	}
	return ans;
}
int main()
{
	int t,i,m,a,b,c,ncase=1;
	freopen("in.txt","r",stdin);
	freopen("out.txt","w",stdout);
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(i=1;i<=n;i++)
			scanf("%d",&tree[0][i]),sorted[i]=tree[0][i];
		sort(sorted+1,sorted+1+n);
		build(1,n,0);
		printf("Case %d:\n",ncase++);
		while(m--)
		{
			scanf("%d%d%d",&a,&b,&c);
			printf("%d\n",solve(a+1,b+1,c));
		}
	}
	return 0;
}


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值