Multiply game
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1375 Accepted Submission(s): 472
Problem Description
Tired of playing computer games, alpc23 is planning to play a game on numbers. Because plus and subtraction is too easy for this gay, he wants to do some multiplication in a number sequence. After playing it a few times, he has found it is also too boring. So he plan to do a more challenge job: he wants to change several numbers in this sequence and also work out the multiplication of all the number in a subsequence of the whole sequence.
To be a friend of this gay, you have been invented by him to play this interesting game with him. Of course, you need to work out the answers faster than him to get a free lunch, He he…
To be a friend of this gay, you have been invented by him to play this interesting game with him. Of course, you need to work out the answers faster than him to get a free lunch, He he…
Input
The first line is the number of case T (T<=10).
For each test case, the first line is the length of sequence n (n<=50000), the second line has n numbers, they are the initial n numbers of the sequence a1,a2, …,an,
Then the third line is the number of operation q (q<=50000), from the fourth line to the q+3 line are the description of the q operations. They are the one of the two forms:
0 k1 k2; you need to work out the multiplication of the subsequence from k1 to k2, inclusive. (1<=k1<=k2<=n)
1 k p; the kth number of the sequence has been change to p. (1<=k<=n)
You can assume that all the numbers before and after the replacement are no larger than 1 million.
For each test case, the first line is the length of sequence n (n<=50000), the second line has n numbers, they are the initial n numbers of the sequence a1,a2, …,an,
Then the third line is the number of operation q (q<=50000), from the fourth line to the q+3 line are the description of the q operations. They are the one of the two forms:
0 k1 k2; you need to work out the multiplication of the subsequence from k1 to k2, inclusive. (1<=k1<=k2<=n)
1 k p; the kth number of the sequence has been change to p. (1<=k<=n)
You can assume that all the numbers before and after the replacement are no larger than 1 million.
Output
For each of the first operation, you need to output the answer of multiplication in each line, because the answer can be very large, so can only output the answer after mod 1000000007.
Sample Input
1 6 1 2 4 5 6 3 3 0 2 5 1 3 7 0 2 5
Sample Output
240 420
Source
解题思路:线段树单点修改,区间求积
#include <iostream>
#include <cstdio>
#include <cstring>
#define Maxn 50005
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define Mod 1000000007
#define LL long long
using namespace std;
LL tree[Maxn<<2];
void push_up(int rt)
{
tree[rt]=(tree[rt<<1]%Mod*tree[rt<<1|1]%Mod)%Mod;
}
void build(int l,int r,int rt)
{
if(l==r)
{
scanf("%d",&tree[rt]);
return ;
}
int m=(l+r)>>1;
build(lson);
build(rson);
push_up(rt);
}
void update(int pos,int x,int l,int r,int rt)
{
if(l==r)
{
tree[rt]=x;
return ;
}
int m=(l+r)>>1;
if(pos<=m)
update(pos,x,lson);
else
update(pos,x,rson);
push_up(rt);
}
int query(int L,int R,int l,int r,int rt)
{
if(L<=l&&R>=r)
return tree[rt];
int m=(l+r)>>1;
LL ans=1;
if(L<=m)
ans=(ans*query(L,R,lson))%Mod;
if(R>m)
ans=(ans*query(L,R,rson))%Mod;
return ans;
}
int main()
{
int t,n,q,x,a,b;
LL ans;
freopen("in.txt","r",stdin);
freopen("out.txt","w",stdout);
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
build(1,n,1);
scanf("%d",&q);
while(q--)
{
scanf("%d%d%d",&x,&a,&b);
if(x==0)
{
ans=query(a,b,1,n,1);
printf("%I64d\n",ans%Mod);
}
else
update(a,b,1,n,1);
}
}
return 0;
}