HDU 1384 Intervals 差分约束

Intervals

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2756    Accepted Submission(s): 1005


Problem Description
You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn.

Write a program that:

> reads the number of intervals, their endpoints and integers c1, ..., cn from the standard input,

> computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i = 1, 2, ..., n,

> writes the answer to the standard output
 

Input
The first line of the input contains an integer n (1 <= n <= 50 000) - the number of intervals. The following n lines describe the intervals. The i+1-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50 000 and 1 <= ci <= bi - ai + 1.

Process to the end of file.

 

Output
The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i = 1, 2, ..., n.
 

Sample Input
  
  
5 3 7 3 8 10 3 6 8 1 1 3 1 10 11 1
 

Sample Output
  
  
6
 

Author
1384
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1529  1548  1317  1596  1385 
解题思路:差分约束,令si表示前i个数中选择了si个数,因为要防止i=0的情况发生,将区间[a,b]映射成[a+1,b+1],还有隐含条件si+1-si>=1;si-si+1<=0;
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#define Maxn 50005
#define Inf 0x3f3f3f3f
using namespace std;
int head[Maxn],k;
int dis[Maxn];
struct
{
	int e,w,next;
}edge[Maxn<<2];
void add(int s,int e,int w)
{
	edge[k].e=e;
	edge[k].w=w;
	edge[k].next=head[s];
	head[s]=k++;
}
int spfa(int s,int n)
{
	int i,st,ed;
	bool vis[Maxn];
	memset(vis,false,sizeof(vis));
	for(i=s;i<=n;i++)
		dis[i]=-Inf;
	dis[s]=0;
	vis[s]=true;
	queue<int> q;
	q.push(s);
	while(!q.empty())
	{
		st=q.front();
		q.pop();
		vis[st]=false;
		for(i=head[st];i!=-1;i=edge[i].next)
		{
			ed=edge[i].e;
			if(dis[ed]<dis[st]+edge[i].w)
			{
				dis[ed]=dis[st]+edge[i].w;
				if(!vis[ed])
				{
					vis[ed]=true;
					q.push(ed);
				}
			}
		}
	}
	return dis[n];
}
int main()
{
	int n,a,b,c,maxn,ans,L,R;
	freopen("in.txt","r",stdin);
	freopen("out.txt","w",stdout);
	while(~scanf("%d",&n))
	{
		k=0;ans=-1;
		memset(head,-1,sizeof(head));
		R=-Inf,L=Inf;
		while(n--)
		{
			scanf("%d%d%d",&a,&b,&c);
			a++,b++;
			add(a-1,b,c);
			L=min(L,a-1);
			R=max(R,b);
		}
		for(int i=L;i<R;i++)
		{
			add(i,i+1,0);
			add(i+1,i,-1);
		}
		printf("%d\n",spfa(L,R));
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值