HDU 3592 World Exhibition 差分约束

World Exhibition

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 931    Accepted Submission(s): 468


Problem Description
Nowadays, many people want to go to Shanghai to visit the World Exhibition. So there are always a lot of people who are standing along a straight line waiting for entering. Assume that there are N (2 <= N <= 1,000) people numbered 1..N who are standing in the same order as they are numbered. It is possible that two or more person line up at exactly the same location in the condition that those visit it in a group.

There is something interesting. Some like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of X (1 <= X <= 10,000) constraints describes which person like each other and the maximum distance by which they may be separated; a subsequent list of Y constraints (1 <= Y <= 10,000) tells which person dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between person 1 and person N that satisfies the distance constraints.
 

Input
First line: An integer T represents the case of test.

The next line: Three space-separated integers: N, X, and Y.

The next X lines: Each line contains three space-separated positive integers: A, B, and C, with 1 <= A < B <= N. Person A and B must be at most C (1 <= C <= 1,000,000) apart.

The next Y lines: Each line contains three space-separated positive integers: A, B, and C, with 1 <= A < B <= C. Person A and B must be at least C (1 <= C <= 1,000,000) apart.
 

Output
For each line: A single integer. If no line-up is possible, output -1. If person 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between person 1 and N.
 

Sample Input
  
  
1 4 2 1 1 3 8 2 4 15 2 3 4
 

Sample Output
  
  
19
 

Author
alpc20
 

Source
 

Recommend
zhouzeyong
  解题思路:基础的差分约束,直接列不等式,然后用SPFA判断即可,如果出现负权环即是不等式无解,如果到第n个人的最短距离一直没有更新就说明第n个人与第1个人在图上是不连通的,就是第n个人与第1个人的距离是任意长度,有更新的话就是有最短距离了,输出即可。
#include<cstdio>
#include<cstring>
#include<queue>
#define Inf 0x7ffffff
using namespace std;
int head[1005],k;
struct
{
	int s;
	int e;
	int w;
	int next;
}edge[20005];
void Add(int s,int e,int w)
{
	edge[k].s=s;
	edge[k].e=e;
	edge[k].w=w;
	edge[k].next=head[s];
	head[s]=k++;
}
int SPFA(int s)
{
	int i,st,ed,dis[1005],cnt[1005];
	bool visit[1005];
	memset(visit,false,sizeof(visit));
	memset(cnt,0,sizeof(cnt));
	for(i=1;i<=s;i++)
		dis[i]=Inf;
	queue<int> x;
	x.push(1);
	dis[1]=0;
	cnt[1]++;
	visit[1]=true;
	while(!x.empty())
	{
		st=x.front();
		x.pop();
		for(i=head[st];i!=-1;i=edge[i].next)
		{
			ed=edge[i].e;
			if(dis[ed]>dis[st]+edge[i].w)
			{
				dis[ed]=dis[st]+edge[i].w;
				if(!visit[ed])
				{
					visit[ed]=true;
					x.push(ed);
					cnt[ed]++;
					if(cnt[ed]>s-1)
						return -1;
				}
			}
		}
		visit[st]=false;
	}
	if(dis[s]==Inf)
		return -2;
	else
		return dis[s];
}
int main()
{
	int i,t,n,x,y,a,b,c,ans;
	scanf("%d",&t);
	while(t--)
	{
		k=0;
		memset(head,-1,sizeof(head));
		scanf("%d%d%d",&n,&x,&y);
		for(i=0;i<x;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			Add(a,b,c);
		}
		for(i=0;i<y;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			Add(b,a,-c);
		}
		ans=SPFA(n);
		printf("%d\n",ans);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值